Rosanswers logo

I'm following the tutorial on Autonomous Navigation of a known map for Turtlebot here


Rviz Shows up, my map shows up, obstacles show up. Everything looks good basically, but whenever I choose a 2D Nav Goal after choosing a 2D Pose Estimate, the TurtleBot won't move to that point. I don't understand why, but here is the output of

roslaunch turtlebot_navigation amcl_demo.launch map_file:=/tmp/my_map.yaml

core service [/rosout] found
process[camera/camera_nodelet_manager-1]: started with pid [4414]
process[camera/openni_camera_loader-2]: started with pid [4442]
process[camera/depthimage_to_laserscan_loader-3]: started with pid [4469]
process[map_server-4]: started with pid [4488]
process[amcl-5]: started with pid [4503]
process[navigation_velocity_smoother-6]: started with pid [4601]
process[move_base-7]: started with pid [4708]
[ INFO] [1376352712.285728199]: Subscribed to Topics: scan
[ INFO] [1376352712.439712463]: Requesting the map...

[ INFO] [1376352712.449757555]: Still waiting on map...

[ INFO] [1376352713.455649136]: Still waiting on map...

[ WARN] [1376352714.479019249]: You have set map parameters, but also requested to use the static map. Your parameters will be overwritten by those given by the map server
[ INFO] [1376352714.479322989]: Received a 608 X 480 map at 0.050000 m/pix

[ WARN] [1376352719.480832367]: Waiting on transform from /base_footprint to /map to become available before running costmap, tf error: 
[ INFO] [1376352723.641302041]: MAP SIZE: 608, 480
[ INFO] [1376352723.685798187]: Subscribed to Topics: scan
[ INFO] [1376352725.433534739]: Sim period is set to 0.20
[ WARN] [1376352725.540824452]: Trajectory Rollout planner initialized with param meter_scoring not set. Set it to true to make your settins robust against changes of costmap resolution.

Originally posted by llSourcell on ROS Answers with karma: 236 on 2013-08-12

Post score: 1

Original comments

Comment by Felix Endres on 2013-08-18:
Hi, I do not now much about turtlebot navigation, but I'd guess your localization doesn't work. Try using tags without hashes (#), so the right people get to see your question.

Comment by bit-pirate on 2014-03-11:
Did initialise the robot's pose on the map?

Comment by Ken_in_JAPAN on 2014-03-12:
I also have same problem. My turtlebot works correctly with keyboard teleop, but doesn't work with an autonomous navigation I follow ROS web(autonomously navigate in a known map). I doubt that /mobile_base/commands/velocity doesn't respond.


1 Answer 1


Rosanswers logo

Update: Try shutting down the teleop node if you have it running in parallel. For some reason it blocks the autonomous navigation even when you aren't sending any commands.

I have the same problem. I am running everything in simulation for now. It worked ONCE when I restarted everything but before and after that it doesn't. I'm using Hydro on Ubuntu 12.04.

I'm actually trying to run it on the Clearpath Husky robot and had some problems with that so thought of trying it on the turtlebot in simulation since Husky packages are based on these. Any help would be appreciated, thank you.

Originally posted by 2ROS0 with karma: 1133 on 2014-07-04

This answer was ACCEPTED on the original site

Post score: 2

Original comments

Comment by Moda on 2014-08-25:
did you solve the issue?

Comment by 2ROS0 on 2014-10-13:
Yes. The teleop node was running in parallel. So.

Comment by cyberguy42 on 2016-03-09:
This solved a similar problem for me.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.