Rosanswers logo

I am trying to calibrate a stereo camera (Logitech Webcam Pro 9000) setup under Ubuntu/Diamondback. I am using usb_cam drivers, which are publishing:


Since the usb_cam drivers do not support the set_camera_info service, I am invoking the cameracalibrator.py with the --no-service-check flag:

rosrun camera_calibration cameracalibrator.py --size 8x6 --square 0.108 --no-service-check right:=/usb_cam_right/image_raw left:=/usb_cam_left/image_raw right_camera:=/usb_cam_right left_camera:=/usb_cam_left

And absolutely nothing happens - no errors, no messages, no gui. The calibrator node is running and is subscribed to the image_raw feeds. Any ideas?

Originally posted by prp on ROS Answers with karma: 118 on 2011-06-19

Post score: 2


2 Answers 2


Rosanswers logo

Are your images synchronized? If you are just using two usb_cam nodes, the timestamps won't ever match on the left/right images, and so you'll never get a matched pair passed to the callback.

Originally posted by fergs with karma: 13902 on 2011-06-22

This answer was ACCEPTED on the original site

Post score: -1


Rosanswers logo

I ran into this same problem. @fergs's answer is the correct diagnosis, but it does not actually help you fix the problem. The gui will only show up when the first pair of synchronized images is received, and if it never receives images at the same time, the gui will never show up.

The solution is to append --approximate=0.005 to your call to tell camera_calibrate to accept unsynchronized images within the given time threshold. I had to use a value as high as 0.1 before it worked with some especially slow USB webcams.

Originally posted by Cerin with karma: 940 on 2015-05-10

This answer was NOT ACCEPTED on the original site

Post score: 1


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.