0
$\begingroup$

Rosanswers logo

Hello, Im trying to get my kinect stereo calibrate so I was following this tutorial:

http://www.ros.org/wiki/camera_calibration/Tutorials/StereoCalibration#Before_Starting

but when I try $ rostopic list, it doesn't show any of the /my_stereo.../ and when I tried

rosrun camera_calibration cameracalibrator.py --size 8x6 --square 0.108 right:=/my_stereo/right/image_raw left:=/my_stereo/left/image_raw right_camera:=/my_stereo/right left_camera:=/my_stereo/left

I got: "Waiting for service /my_stereo/left/set_camera_info ... Service not found Waiting for service /my_stereo/right/set_camera_info ... Service not found"

I also tried the Monocular Camera calibration on: http://www.ros.org/wiki/camera_calibration/Tutorials/MonocularCalibration and got the same problem "Waiting for service /camera/set_camera_info ... Service not found" with $ rosrun camera_calibration cameracalibrator.py --size 8x6 --square 0.108 image:=/camera/image_raw camera:=/camera

What im doing wrong? What should I do? Im working on ubuntu 12.04 and ros fuerte.

thanks!


Originally posted by Fer Nunez on ROS Answers with karma: 11 on 2012-08-01

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

The kinect is not a (traditional) stereo camera, so the stereo calibration will not work. There is a wiki page which details how to calibrate a kinect properly.

There isn't quite enough information to figure out why the set_camera_info service can't be found. Could you edit your question to add the exact command you're using the launch the camera driver?


Originally posted by Dan Lazewatsky with karma: 9115 on 2012-08-01

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.