0
$\begingroup$

Rosanswers logo

Hi everybody,

I am trying to install gscam http://wiki.ros.org/gscam ans I have many problems . First, when I did the command rosrun gscam gscam I had the warning
"Camera calibration file .ros/camera_info/camera.yaml not found."
So I find a camera.yaml and add it. Now I have the warning
"[camera] does not match name ~ in file .ros/camera_info/camera.yaml"
I think I have to add the camera name in the file but I can't find it with lsusb. If someone knows how to find it, it will really help me.

And as it is only a warning, I think I still can run the command. I have something like :

[ INFO] [1396441119.700854095]: Loaded camera calibration from
[ INFO] [1396441119.743789905]: Time offset: 1396352825,277
[ INFO] [1396441120.290373939]: Publishing stream...
[ INFO] [1396441120.290746518]: Started stream.
and my webcam is turned on but when I tried to display it with "rosrun image_view image_view image:=/gscam/image_raw" a small blank window pops up, but without any picture or video from my camera.
So I did a "rostopic hz --window=1000 /gscam/image_raw" to see what is published, but there are no messages published by the node.

When I list the topic, I have all topics published by gscam .
/camera/camera_info
/camera/image_raw
/camera/image_raw/compressed
/camera/image_raw/compressed/parameter_descriptions
/camera/image_raw/compressed/parameter_updates
/camera/image_raw/compressedDepth
/camera/image_raw/compressedDepth/parameter_descriptions
/camera/image_raw/compressedDepth/parameter_updates
/camera/image_raw/theora
/camera/image_raw/theora/parameter_descriptions
/camera/image_raw/theora/parameter_updates
/rosout /rosout_agg

And "rosrun rqt_graph rqt_graph" shows me the /gscam_publisher node and the /image_view nodeb and they are not linked.

I don't know what to do. Can somedody help me please?
Thank you


Originally posted by RosFaceNoob on ROS Answers with karma: 42 on 2014-04-02

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

You should not add some random camera.yaml file, but one that is the result from calibrating your camera. Nevertheless the publishing of images should still work, even if the calibration parameters are likely quite wrong.

Start the driver, and execute rostopic list in another terminal. Edit your question and include the exact output of that command.

EDIT:

From the output you can see that the topic names of image view and gscam do not match. You should run image_view with the following arguments:

rosrun image_view image_view image:=/camera/image_raw

Originally posted by demmeln with karma: 4306 on 2014-04-02

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.