Rosanswers logo

Hi everyone

I have three different versions of ROS installed on my system and i want to unistall Hydro. I can not do it with

sudo apt-get remove ros-hydro

I think it is a wrong command. Does anyone know how should i do it??? thanks:))

I could unistall it successfully and I tried to reinstall hydro because it had some problems. When i try again i see:

The following packages have unmet dependencies: ros-hydro-desktop-full : Depends: ros-hydro-simulators but it is not going to be installed E: Unable to correct problems, you have held broken packages.

Does anyone know what is the problem??

Originally posted by mohammad on ROS Answers with karma: 75 on 2014-09-29

Post score: 0


1 Answer 1


Rosanswers logo

how about

sudo apt-get remove ros-hydro-*

Originally posted by whiterose with karma: 148 on 2014-09-29

This answer was ACCEPTED on the original site

Post score: 2

Original comments

Comment by mohammad on 2014-09-29:
it works. thanks:))

Comment by tfoote on 2014-09-30:
@mohammad please accept the answer using the checkmark at left so others know your problem is solved.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.