0
$\begingroup$

Rosanswers logo

About six months ago I was able to use Ubuntu 12.04 and sudo-apt-get to install ros-hydro-navigation without any dependency errors. Trying to do this a second BBB has not been as easy ros-base installed easily, but navigation now has many dependency problems. I suspect these are related to libboost version problems (my version is 1.46), but I am not sure:

The following packages have unmet dependencies:

 ros-hydro-navigation : Depends: ros-hydro-amcl but it is not going to be installed
                    Depends: ros-hydro-base-local-planner but it is not going to be installed
                    Depends: ros-hydro-carrot-planner but it is not going tobe installed
                    Depends: ros-hydro-clear-costmap-recovery but it is not  going to be installed
                    Depends: ros-hydro-costmap-2d but it is not going to be installed
                    Depends: ros-hydro-dwa-local-planner but it is not going  to be installed
                    Depends: ros-hydro-fake-localization but it is not going to be installed
                    Depends: ros-hydro-map-server but it is not going to be  installed
                    Depends: ros-hydro-move-base but it is not going to be installed
                    Depends: ros-hydro-move-slow-and-clear but it is not going to be installed
                    Depends: ros-hydro-nav-core but it is not going to be installed
                    Depends: ros-hydro-navfn but it is not going to be installed
                    Depends: ros-hydro-robot-pose-ekf but it is not going to  be installed
                    Depends: ros-hydro-rotate-recovery but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

the following did install:

  • ros-hydro-ros-base
  • python-rosdep
  • ros-hydro-sensor-msgs
  • ros-hydro-image-transport
  • ros-hydro-uvc-camera
  • ros-hydro-dynamic-reconfigure
  • ros-hydro-common-msgs

Originally posted by DrBot on ROS Answers with karma: 147 on 2014-08-31

Post score: 0


Original comments

Comment by DrBot on 2014-09-01:
Upgrading libboost from 1.46 to 1.48 did not work, in fact it removed all of the ros packages.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

sudo aptitude install ros-hydro-navigation

Seemed to work - issue was with c libraries. So it might be when I installed build-essentials, it was with the wrong flavor.

Darn, It took me two days to figure out this one. It is helps to be stubborn.


Originally posted by DrBot with karma: 147 on 2014-09-01

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.