0
$\begingroup$

Rosanswers logo

Hi everyone,

As per the last update of ROS Hydro, I have compatibility issues with OpenNI packages. It seems to me that not all packages released in the standard distribution are using OpenNI as a system dependency, so I keep getting conflicts in apt-get.

I just uninstalled ROS Hydro and Groovy, as well as OpenNI. When reinstalling ROS Hydro, I see the package "openni-dev" is being installed along with everything else. When I try to install "ros-hydro-openni-*", however, I get the following error:

georgebrindeiro@r2d2:~$ sudo apt-get install ros-hydro-openni-*
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'ros-hydro-openni-launch' for regex 'ros-hydro-openni-*'
Note, selecting 'ros-hydro-openni-camera' for regex 'ros-hydro-openni-*'
Note, selecting 'ros-hydro-openni-tracker' for regex 'ros-hydro-openni-*'
Note, selecting 'ros-hydro-openni2-camera' for regex 'ros-hydro-openni-*'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-hydro-openni-camera : Depends: libopenni0 but it is not going to be installed
                           Depends: libopenni-dev but it is not going to be installed
                           Depends: libopenni-sensor-primesense-dev but it is not going to be installed
 ros-hydro-openni-tracker : Depends: libopenni0 but it is not going to be installed
                            Depends: libopenni-dev but it is not going to be installed
                            Depends: libopenni-nite-dev but it is not going to be installed
                            Depends: libopenni-sensor-primesense-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

libopenni* and openni-dev seem to be mutually exclusive. If I try to remove openni-dev, however, apt-get requires me to remove PCL and loads of packages. I am assuming the problem is with the openni packages... How do we solve this?

EDIT: This is also happening with ROS Groovy


Originally posted by georgebrindeiro on ROS Answers with karma: 1264 on 2013-09-11

Post score: 2

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Hi, I too had the same issues. it was caused by an older version of pcl standalone installation. So i uninstalled all PCL, Openni packages, then removed a ppa of pcl from synaptic. Now it works fine


Originally posted by achuwilson with karma: 128 on 2013-09-19

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by georgebrindeiro on 2013-09-19:
That's exactly what I did yesterday and it worked fine. Thanks for documenting the answer though, I had done it only on the associated github issue.

Comment by ubisum on 2013-10-22:
hi. i'm just a kinux/ros newbie. could you tell how to do all this? thanks.

Comment by Seanny123 on 2013-11-04:
Is there an option where I don't do that? I need my current PCL and Openni installation... Can you link to the github bug you reported?

Comment by georgebrindeiro on 2013-11-06:
Seanny123, here's the GitHub issue I reported: https://github.com/ros-drivers/openni_camera/issues/19 (ROS Answers keeps adding a trailing tag to my link, no idea why)

Comment by georgebrindeiro on 2013-11-06:
Why do you need your current PCL/OpenNI installations, though? If your problem is unrelated, I suggest you create a new issue.

Comment by AlexR on 2015-02-04:
can you describe the steps to remove the standalone version of pcl . The PCL page does not seem to have a good tutorial on removing pcl. Thanks

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.