Rosanswers logo


I am using a Pioneer 3dx with a Sick lms 200 Laserscanner. I wanted to access the robot via ROS and the already supported p2os_driver. Everything works fine including the transformation from base_link to laser_scanner and so on. Now my Problem:

I did the navigation stack tutorial and created the files like its told in the tutorial. I started all relevant things (p2os driver for odom and tf, laser_wrapper, transformation from laser to baselink and slam gmapping for the map) after that I launched the move_base.launch file and got some warnings and errors:

[ WARN] [1310979131.605673459]: Planner specifications should now include the package name. You are using a deprecated API. Please switch from NavfnROS to navfn/NavfnROS in your yaml file.

In which file do I have to adjust the path? I can't find it.

[ERROR] [1310979131.801336625]: You are using acc_limit_x where you should be using acc_lim_x. Please change your configuration files appropriately. The documentation used to be wrong on this, sorry for any confusion.

I checked the used yaml-Files and I am using only acc_lim_x variables. The error occurs for x,y and th. Where else can this error come from?

[ WARN] [1310978768.698218184]: Map update loop missed its desired rate of 2.0000Hz... the loop actually took 2.1595 seconds

Whats that? I am totally confused with all these warnings and errors.

Same with that warning:

[ WARN] [1310979131.859018260]: The backup_vel parameter has been deprecated in favor of the escape_vel parameter. To switch, just change the parameter name in your configuration files.

Despite of all warnings I started rviz and was happy to see the occupacy grid map but the rest of the navigation didnt work. There are warnings in rviz that the topics dont recieve any data... I tried to set an estimated pose and navigate to somewhere but no chance of moving the bot. Why? What is wrong with my config?

I read everything about my problem here in the answers.ros.org but couldn't find anything helpful so i created an own question.

thanks for your help.



The code of the config-files:


<master auto="start"/>

<!-- Run the map server (you can run it here or in another terminal) -->
<!-- <node name="map_server" pkg="map_server" type="map_server" args="path_to_map.yaml"/> -->

<!--- Run AMCL -->
<include file="$(find p2os_launch)/amcl.launch" />

<node pkg="move_base" type="move_base" respawn="false" name="move_base" output="screen">
    <rosparam file="$(find p2os_launch)/costmap_common_params.yaml" command="load" ns="global_costmap" />
    <rosparam file="$(find p2os_launch)/costmap_common_params.yaml" command="load" ns="local_costmap" />
    <rosparam file="$(find p2os_launch)/local_costmap_params.yaml" command="load" />
    <rosparam file="$(find p2os_launch)/global_costmap_params.yaml" command="load" />
    <rosparam file="$(find p2os_launch)/base_local_planner_params.yaml" command="load" />
    <param name="base_global_planner" type="string" value="navfn/NavfnROS" />
    <!--  <param name="conservative_reset_dist" type="double" value="3.0" /> -->
    <!--  <param name="controller_frequency" type="double" value="15.0" /> -->

I already tried the diff_amcl.launch in the examples but there are even more errors and the map cant be found...


global_frame: /odom
robot_base_frame: base_link
update_frequency: 5.0
publish_frequency: 2.0
static_map: false
rolling_window: true
width: 5.0
height: 5.0
resolution: 0.05


global_frame: /map
robot_base_frame: base_link
update_frequency: 5.0
static_map: false
rolling_window: true


obstacle_range: 2.5
raytrace_range: 3.0
inflation_radius: 0.35

#---standard pioneer footprint---

#---(in meters)---
footprint: [ [0.254, -0.0508], [0.1778, -0.0508], [0.1778, -0.1778], [-0.1905, -0.1778], [-0.254, 0], [-0.1905, 0.1778], [0.1778, 0.1778], [0.1778, 0.0508], [0.254, 0.0508] ]

#transform_tolerance: 0.2
#map_type: costmap

observation_sources: laser_scan_sensor

laser_scan_sensor: {sensor_frame: laser, data_type: LaserScan, topic: scan, marking: true, clearing: true}

#point_cloud_sensor: {sensor_frame: frame_name, data_type: PointCloud, topic: topic_name, marking: true, clearing: true}


  max_vel_x: 1.2
  min_vel_x: 0.2
  max_rotational_vel: 0.8
  min_in_place_rotational_vel: 0.3
 #sim_time: 2.0
  path_distance_bias: 0.6
  goal_distance_bias: 0.6

  acc_lim_th: 3.2
  acc_lim_x: 2.5
  acc_lim_y: 2.5

  holonomic_robot: true

Originally posted by jan on ROS Answers with karma: 28 on 2011-07-17

Post score: 0

Original comments

Comment by jan on 2011-07-18:
Oh sorry. I edited my comment with the code. If you want any other information please let me know.

Comment by eitan on 2011-07-18:
Jan, any chance you could post your configuration files here? That'll make it much easier to track down what's going on.


2 Answers 2


Rosanswers logo

The parameter dump above looks more reasonable. A couple of questions/comments.

  • You should make sure that your "inflation_radius" parameter is set to be larger than the radius of the robot. I'm actually surprised that you're not getting a warning about this because you should be.

  • Have you tried to "rostopic echo cmd_vel" to see if move_base is trying to publish velocity commands.

  • Why are you running both gmapping and AMCL? It should probably be one or the other.

  • Does the global plan created by the navigation stack look reasonable in rviz?

  • Have you looked at the navigation tuning guide to make sure that things are set up more or less correctly for navigation.

Originally posted by eitan with karma: 2743 on 2011-07-26

This answer was NOT ACCEPTED on the original site

Post score: 1


Rosanswers logo

Ok I solved the problem. I had to set the ROS_IP to my own ip. I am using two Ubuntu machines cause the pc on the bot is not powerful enough for rviz and so on. All I had to do was setting the ROS_IP to my local machines IP and the set_2d_nav_goal of rviz worked!

Thank you all for your help

Originally posted by jan with karma: 28 on 2011-08-15

This answer was ACCEPTED on the original site

Post score: 0


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.