Rosanswers logo

Hi all!

I am following this tutorial http://www.ros.org/wiki/navigation/Tutorials/RobotSetup. I am running it using stage. While I am running the move base part, I get such error:

[ WARN] [1336375509.493321469, 8.800000000]: The origin for the sensor at (4.75, 4.00, -0.43) is out of map bounds. So, the costmap cannot raytrace for it.

Hovever when I am using rviz it seams that it is able to work correctly sometimes.

Do you know any solution for this issue?

This are my yaml files:


TrajectoryPlannerROS: max_vel_x: 0.45 min_vel_x: 0.1 max_rotational_vel: 1.0 min_in_place_rotational_vel: 0.4

acc_lim_th: 3.2 acc_lim_x: 2.5 acc_lim_y: 2.5

holonomic_robot: true

costmap_common_params.yaml :

obstacle_range: 7.0 raytrace_range: 3.0 footprint: [[-0.7, -0.55], [-0.7, 0.55], [0.7, 0.55], [0.7, -0.55]] inflation_radius: 0.5 observation_sources: laser_scan_sensor

laser_scan_sensor: {sensor_frame: base_laser, data_type: LaserScan, topic: base_scan, marking: true, clearing: true}

global_costmap_params.yaml :

global_costmap: global_frame: /map robot_base_frame: base_link update_frequency: 5.0 static_map: true


local_costmap: global_frame: odom robot_base_frame: base_link update_frequency: 2.0 publish_frequency: 5.0 static_map: true rolling_window: true width: 36000.0 height: 25000.0 resolution: 0.01

Best regards Tomasz Kucner

Originally posted by tomek on ROS Answers with karma: 3 on 2012-05-07

Post score: 0


1 Answer 1


Rosanswers logo

Hi, We had that same error message here, and we solved it by adding this line

map_type: costmap

both to the local_costmap_params.yaml and to the global_costmap_params.yaml. cheers.

Originally posted by Procópio with karma: 4402 on 2012-05-07

This answer was ACCEPTED on the original site

Post score: 1


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.