Rosanswers logo

Hi everywhere.

I'm finishing the install of the navigation stack on my robot, but I have a problem. As I viewed in the tutorial "Using rviz in navigation stack", the obstacles and inflated obstacle will appear as the robot are approximating to them and always that the laser can "view" them. If you see my video, you can note that some obstacles on my rviz are "loaded" since the first moment, and the others will not appear although the laser are viewing it (I note that if the robot collision with this "invisible" obstacles, it see this obstacles).

Video: http://youtu.be/rBaU9yuqO6k

I searched and found some topics in forums of people that have a similar problem (altough they directly not see the obstacles), but I try to apply some changes proposed and the result is the same.

There are some of my configuration files:


obstacle_range: 0.05

raytrace_range: 0.5

footprint:[[0.5, -0.275], [0.5, 0.275],[-0.5,0.275], [-0.5, -0.275]]

inflation_radius: 0.5

observation_sources: laser_scan_sensor laser_scan_sensor: {sensor_frame: /hokuyo_laser_link, data_type: LaserScan, topic: hok_node_topic, marking: true, clearing: true}

global_frame: /map
robot_base_frame: base_link
update_frequency: 5.0 static_map: true

global_frame: odom
robot_base_frame: base_link
update_frequency: 5.0
publish_frequency: 2.0 static_map: true rolling_window: true width: 6.0 height: 6.0 resolution: 0.05

Other problem that I have is to synchronize the position of the robot both in Gazebo and Rviz I have to set manually in this last. There is other method?

Any idea? Thanks in advance!

Originally posted by mbj on ROS Answers with karma: 197 on 2011-05-31

Post score: 0

Original comments

Comment by mbj on 2011-06-01:
It's a forum copy-paste error. When I asked the question I noticed that this was different than in the local file (in the local file there aren't newlines and doesn't appears "costmap_common_params.yaml:"), but I tried to rewrite it without success.

Comment by eitan on 2011-06-01:
The format of the YAML file you posted is a bit strange, its possible that its a copy-paste error, but could you re-post it with the proper newlines? I just want to make sure that the file you're actually using in practice contains the newlines it needs.


1 Answer 1


Rosanswers logo

OK.. just wanted to make sure before I really dug into things. After taking a closer look, it seems like you have "static_map" set to true for your local_costmap, which means that the width, height, and resolution parameters you set are all ignored. Try setting "static_map" to false and see what happens. You may also have an issue with sensor data coming into the costmap, but I'd try this first.

As for using the information from gazebo as a localization source, the fake_localization package will be of interest since, I believe, Gazebo publishes some sort of ground truth message.

Originally posted by eitan with karma: 2743 on 2011-06-02

This answer was ACCEPTED on the original site

Post score: 1

Original comments

Comment by mbj on 2011-06-08:
I think that I solved part of the problem. I changed in global and local costmap_parameter files the robot_base_frame to /base_footprint and it runs, but what I would to modify to "see" the objects before and expand the laser vision? I tried modifiying the "laser_min_range" and "laser_max_range" to -2.09 and 2.09 rads to set this like in the urdf (-120º/120ª) but I not see any difference.

Comment by mbj on 2011-06-02:
I changed the parameter "static_map" to false in my local_costmap and no obstacle/inflated_obstacle is viewed. When I launch the move_base node, I see that costmap_common_params load correctly the laser_scan, and If I "echo" the topic "/move_base/local_costmap/obstacles" I have messages with frame_id: /odom and all the values except cells[]. I think and read that this cells:[] array must not be empty, but all the solutions that I found are based in a bad configuration of the laser_scan or any tf problem, and I not see any of these two errors... Do you have another idea? Thanks!


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.