Rosanswers logo

Hi all, I'm having problems with movebase on pioneer robot. working with Ubuntu 12.04 LTS and Fuerte. The problem is that the robot is not avoiding the obstacles. i can see in rviz that there are obstacles in the map. so i suppose the laser scanner and gmapping is working properly. but when giving targets behind the obstacles (using 2D Nav Goal in rviz), the robot dose not avoid some obstacles and keep crashing with them!!!

I don't know exactly how movebase is working. but i can see(actually hear) that the sonars in the pioneer is not activated!

Any suggestions?

costmap_common.yaml :

map_type: costmap transform_tolerance: 0.5 obstacle_range: 2.5 max_obstacle_height: 2.0 raytrace_range: 3.0 inscribed_radius: 0.35 circumscribed_radius: 0.4 inflation_radius: 0.6 cost_scaling_factor: 15.0 lethal_cost_threshold: 100

observation_sources: laser_scan_sensor point_cloud_sensor laser_scan_sensor: {sensor_frame: laser, data_type: LaserScan, topic: scan, marking: true, clearing: true} point_cloud_sensor: {sensor_frame: sonar_frame, data_type: PointCloud, topic: /RosAria/sonar, marking: true, clearing: true}


global_costmap: global_frame: map
robot_base_frame: base_link
update_frequency: 1.0
publish_frequency: 0.5
raytrace_range: 30.0 obstacle_range: 5.0 static_map: false rolling_window: false width: 100.0
height: 100.0 resolution: 0.05
origin_x: -30.0 origin_y: -30.0

Originally posted by Anas Alhashimi on ROS Answers with karma: 179 on 2014-01-09

Post score: 0

Original comments

Comment by dornhege on 2014-01-09:
How did you configure the costmaps for move_base? Do they contain the obstacle sources that you see in rviz?

Comment by Anas Alhashimi on 2014-01-09:
hello dornhege and thanks for your fast comment. I have costmap_common.yaml for global and local with global_costmap.yaml for global only. but i don't think there is a parameter about obstacle sources! i added the files below.

Comment by dornhege on 2014-01-10:
It seems there are some sensor sources configured. Can you check in rviz if those exact sensor sources also appear in the costmap? One issue might be that one sensor clears data from another.


1 Answer 1


Rosanswers logo

I think I found the problem! :) It was in the 'sensor_frame: ' in place it was 'laser' and in other place it was 'laser_link'. Also I fixed the sonar problem and they are working fine now.

I will try to add the bumpers to the observation_sources in the next step to make it more reliable. Thanks a lot.

Originally posted by Anas Alhashimi with karma: 179 on 2014-01-10

This answer was ACCEPTED on the original site

Post score: 0


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.