Rosanswers logo

Does anyone know what or when to expect the new XBOX One Kinect sensor to work with ROS (Openni2?)

Originally posted by TFinleyosu on ROS Answers with karma: 385 on 2013-12-10

Post score: 13


2 Answers 2


Rosanswers logo

EDIT : Thiemo from the Institute for Artificial Intelligence at the University of Bremen has released a kinect v2 driver! Check out this post from ROS news for more info.

The folks over at openkinect seem to be hard at work in hacking kinect v2. There's not much info on the wiki page as of this post, but some of the threads on the forums are quite encouraging.

Originally posted by thebyohazard with karma: 3562 on 2014-01-20

This answer was ACCEPTED on the original site

Post score: 9

Original comments

Comment by isura on 2014-07-10:
Any update on this?

Comment by Cyril Jourdan on 2014-12-12:
Anyone managed to get the skeleton tracking with the Kinect v2 ? that would be awesome^^!

Comment by srik11 on 2016-01-17:
Any update on the new kinect (kinect for xbpx one) ? Has anyone managed to get it run.? Would highly appreciate your help regarding the same.

Comment by Cyril Jourdan on 2016-01-18:
I got it working on Ubuntu 14.04 and ROS Indigo up to the point where I can see the colored point cloud in Rviz. I think you just have to follow the instructions here : https://github.com/code-iai/iai_kinect2

Comment by srik11 on 2016-01-18:
Hey, I tried the same. I installed libfreenect2. But for me the issue is that I cannot even run with Protonect. So I was wondering whether my USB controller has any issue. I get no devices found when I run Protonect. Although the USB port is USB 3.0. Which USB controller are you using?

Comment by Cyril Jourdan on 2016-01-19:
I also use USB3.0. Do you see the kinect listed with the lsusb command ? Did you try to run Protonect with the options gl, cl or cpu ?

Comment by srik11 on 2016-01-20:
Hey!, Thanks, found the issue. libusb was not the latest version. But now Protonect runs with cpu and gl but does not run with cl. I am guessing opencl is not completely installed. I have an intel GPU, so i am not able to install beignet. for my kernel 3.16. Did you face this issue?

Comment by Cyril Jourdan on 2016-01-20:
In the beginning I also had issues, I saw only black windows with no data I remember. I have a nVidia GPU. There was a rely I gave, you can have a look : http://answers.ros.org/question/209393/how-can-i-use-kinect-v2-with-ros-in-ubuntu-1404/ Did you get the kinect2_bridge working ?

Comment by thebyohazard on 2016-01-21:
You guys should really ask a new question so others can benefit from your answers.


Rosanswers logo

The XBox One Kinect is completely different technology from the XBox 360 Kinect. It will not work with openni2. Someone is going to need to reverse engineer the new Kinect's protocol again unless Microsoft releases a linux SDK. (Not likely.)

Originally posted by tfoote with karma: 58457 on 2013-12-15

This answer was NOT ACCEPTED on the original site

Post score: 2

Original comments

Comment by BennyRe on 2013-12-16:
Does anybody know if someone started working on this?


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.