Gazebo Answers logo

Looks like GpuRaySensor.hh went missing in Gazebo 1.3. I checked out the lastest source from the repo:

~/src/gazebo$ ls gazebo/sensors/Gpu*
gazebo/sensors/GpuRaySensor.cc  gazebo/sensors/GpuRaySensor.hh

But in my installed (Ubuntu package), there is no more GpuRaySensor:

/usr/include/gazebo-1.3$ ls gazebo/sensors/Gpu*
ls: cannot access gazebo/sensors/Gpu*: No such file or directory

Pretty sure it was there in 1.2 and earlier as I had compiled worked on an extension to the base GpuRaySensor class.


Because I am impatient, I tried pulling in the relevant sources into my sensor that were missing from installed Gazebo 1.3 (GpuRaySensor.hh/.cc, GpuLaser.hh/.cc). But then ran into the following compile error:

In file included from .../plugins/src/GpuLaser.cc:27:0:
/usr/include/gazebo-1.3/gazebo/rendering/ogre_gazebo.h:22:18: fatal error: Ogre.h: No such file or directory

Looks like Ogre.h is in,


Not in,


Ultimately is this why GpuLaser didn't make it into 1.3?

Originally posted by yamokosk on Gazebo Answers with karma: 13 on 2012-12-12

Post score: 0


1 Answer 1


Gazebo Answers logo

Here's a gpu_sensors branch that should at least compile for you.

Opened an issue and a pull request.

It was not merged because we didn't get a chance to remove rendering::GpuLaser dependency on sensors::GpuRaySensor. Work in progress (see the pull request above).

Originally posted by hsu with karma: 1873 on 2012-12-12

This answer was ACCEPTED on the original site

Post score: 1


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.