This is not really a problem but something strange is going on.

When Create2 is connected to a PC via the USB original connector lead, when you start-up the computer the Create2 is activated by the Baud Rate Change (BRC) pulling to ground. If I understand correctly, normal behaviour.

My Create2 is connected to a XBEE via a buck converter, I added a switch so the buck converter and the XBEE should not drain the battery continuously so as mentioned in the specs.

I followed the Bluetooth pdf for the connections, its working well for sending commands but I still just have a few problems with streaming the return data but that will be resolved.

But now, with the XBEE switched off my Create2 still activates when I start-up my PC, how is that possible, how can the BRC be pulled to ground?

There can be no communication between the PC XB and the Create2 XB since the Create2 XB is switched off, only the PC XB is switched on when starting the computer.

Its not a problem, its just that I am puzzled. Can anyone explain why this is happening?

So, am I understanding this correctly that there is no physical connection between your Create 2 and your PC when going by the XBEE - only a bluetooth connection?

If you say the Create 2 XBee is switched off, then it sounds like a hardware failure of the switch on the Create 2's XBee. Not uncommon with cheaper/smaller switches, the switch just happened to fail in the 'on' position. Try switching the Xbee on the PC off and rebooting the PC, see if the signal still gets through (just to eliminate the PC XBee as the malfunction).

Pull the create 2 XBee, and check the continuity of the switch with a simple DMM (check the resistance - high for 'off', low for 'on', no change for 'broken').

  • If you are going to correct spelling and grammer, it's a good idea to correct all of the problems, otherwise a reviewer might reject your suggested edits. In this case, I decided to do the edits you missed. Also, please don't correct British English to American English, it isn't necessary and some people get offended at the presumption. Please just accept either when it comes to British/America/other English spellings. – Mark Booth Feb 7 '16 at 5:02
  • My bad on the american-to-british, that one was an honest mistake. It is pretty late on my local time, thought I was careful. – MechanicalMan Feb 7 '16 at 5:06
  • First of all thanks for the reply. Xbee is not Bluetooth do. – xavier22 Feb 7 '16 at 10:42
  • I checked the switch and its completely OFF and yes, there is no physical connection between the two. – xavier22 Feb 7 '16 at 10:59
  • Even more stranger, the Create2 does not activate now, even after 2 reboots and even with the switch on. It only seems to activate at first startup in the morning :) – xavier22 Feb 7 '16 at 11:08

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.