Rosanswers logo


We're working on our robot running Ubuntu 14.04 and ROS indigo. Currently, we are trying to connect a Sick TIM 571 laserscanner via ethernet and the Ubuntu 14.04 tries to connect to the Ethernet but it keeps on failing and never connects to it. It works perfectly in Windows using the SOPAS Engineering Tool. Also I installed ROS drivers http://wiki.ros.org/sick_tim and when I run the following command : roslaunch sick_tim sick_tim571_2050101.launch, I keep on getting the following error :

[FATAL] [1459886892.692926805]: Could not resolve host: ... (1)(Host not found (authoritative))
[FATAL] [1459886892.693107727]: Failed to init device: 1
[ERROR] [1459886892.693164271]: sendSOPASCommand: socket not open

SOPAS - Error stopping streaming scan data!
sick_tim driver exiting.

I have also tried (from http://answers.ros.org/question/207220/connecting-a-sick-laserscanner-via-ethernet/):
"On edit connections, click add, go to ethernet tab, set device MAC address to the right ethernet port, got to IPv4 Settings tab, set method to Manual and enter these settings: Address: Netmask: Leave Gateway open and click save." but this also does not help in setting up the ethernet connection between SICK TIM 571 and Ubuntu 14.04.

I am not able to PING the sensor or anything because it is not even getting connected to the Ubuntu 14.04.
Does anyone know how can I set up the ethernet connection between SICK TIM 571 and Ubuntu 14.04?

Thanks in advance.
Naman Kumar

Originally posted by Naman on ROS Answers with karma: 1464 on 2016-04-05

Post score: 0

Original comments

Comment by JohnDoe2991 on 2016-04-06:
Did you edit the sick_tim571_2050101.launch to enable TCP connection? Have you accidently changed the Tim's default IP address? Are you connecting the Tim directly to your Ubuntu or is a router/DHCP/switch between them?

Comment by JohnDoe2991 on 2016-04-06:
If you haven't changed the default IP address and you connect the TIM directly to your Ubuntu, you need to set a static IP address in Ubuntu to, because conflicts with the default Tim IP address

Comment by Naman on 2016-04-06:
Yeah.. I did edit the sick_tim571_2050101.launch.. and I am connecting TIM directly to the Ubuntu. Yeah.. I think it is some IP conflict issue. How can I set a static IP address in Ubuntu to Thanks in advance.

Comment by JohnDoe2991 on 2016-04-06:
Take only Step 1 from this HowTo and then restart your system. You don't need to add the gateway line.

Comment by hashim on 2016-07-26:
@Naman have you resolved your issue. And can you tell me how ? i have the similar issue as yours


1 Answer 1


Rosanswers logo

Maybe this issue will help you: sick_tim #34.

Originally posted by Martin Günther with karma: 11816 on 2016-04-18

This answer was ACCEPTED on the original site

Post score: 2


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.