Rosanswers logo

Hey guys,

I am facing some problems with my hokuyo (UTM-30LX-EW, so the ethernet Scanner). I just downloaded the urg_node stack (with synaptic package manager) and tried to run

rosrun urg_node urg_node _ip_adress:=""

I received an error:

[ERROR] [1424702059.927639563]: Error connecting to Hokuyo: Could not open serial Hokuyo:
/dev/ttyACM0 @ 115200
could not open serial device.

So for me it looks like it thinks its an USB device. What did I wrong? My network connections are pretty easy for use with hokuyo, I just have an ethernet connect while I am connected with the hokuyo:

  • manual ipv4 settings
  • adress:
  • netmask
  • gateway: I am directly connected with the hokuyo so no switch in between.

I already found some questions for this on the answers page but nothing helped me so far. On windwos with UrgBenri tool everything works fine so the laser isnt broken or smth :)

So after this is what i basically want is to write a simple subscriber which receives an array of distances from the LIDAR. But actually the tutorials (Wrtiting a simple publisher and subscriber) and also the wiki of the hokuyo on the ros page doesnt help me a lot for this. Can you give me some advices how can I find a first approach?

Thanks in advance

Oh yea: Running Ubuntu 14.04 and Indigo

Originally posted by schultza on ROS Answers with karma: 232 on 2015-02-23

Post score: 0


1 Answer 1


Rosanswers logo

You have a typo in your parameter name. It has to be "ip_address". not "ip_adress". :)

Originally posted by Stefan Kohlbrecher with karma: 24361 on 2015-02-23

This answer was ACCEPTED on the original site

Post score: 3

Original comments

Comment by schultza on 2015-02-23:
Oh ok :) I didn't copy it just typed it here. I cant Test it right now but I will asap. Assumimg i typed it currently should it work like this?

Comment by Stefan Kohlbrecher on 2015-02-23:
Yes, it works as intended on my machine without the typo (and fails with it as you describe).

Comment by schultza on 2015-02-24:
Can you also help me with my other question?


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.