Rosanswers logo

So I ran: roslaunch gazebo_ros empty_world.launch

to start Gazebo in an empty world. The gazebo window pops up but the terminal stops at this: gazebo/set_physics_properties] has not been advertised, waiting...

Msg Connected to gazebo master @ Msg Publicized address: [ INFO] [1456083864.004714895, 0.024000000]: waitForService: Service [/gazebo/set_physics_properties] is now available. [ INFO] [1456083864.126850646, 0.140000000]: Physics dynamic reconfigure ready.

Msg Connected to gazebo master @ Msg Publicized address:

Even after waiting for awhile, the terminal seems to be stuck at this point and does not allow me to type any commands. I've tried redoing the command multiple but it keeps stopping at the same point.

Originally posted by meep on ROS Answers with karma: 1 on 2016-02-21

Post score: 0


1 Answer 1


Rosanswers logo

roslaunch does not return control of the terminal until all of the nodes in the roslaunch file exit, and gazebo does not usually accept input from the command line.

In short, it sounds like gazebo is working.

Are you able to interact with the gazebo window that pops up? What else do you expect it do?

Originally posted by ahendrix with karma: 47576 on 2016-02-21

This answer was ACCEPTED on the original site

Post score: 1

Original comments

Comment by meep on 2016-02-21:
Yes thank you I figured it out. New to ros sorry.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.