0
$\begingroup$

Rosanswers logo

Hi I am able to run hand_interaction without any issue .But after it detects a human on the on the prime sense user tracker view it always shows "looking for pose" on the detected human.Is there any specific pose link the openni_tracker .plz help the below is the copy of terminal window running hand _interaction.

I have some error like "libusb couldn't open USB device /dev/bus/usb/001/014: Permission denied. libusb requires write access to USB device nodes. " which i have solved

but i still am not able to find why it is not able to detect hand

roslaunch hand_interaction hand_detector.launch ... logging to /home/usr1/.ros/log/7cfb26b2-8555-11e1-975c-38607793109f/roslaunch-CrevaviWS2-1004.log Checking log directory for disk usage. This may take awhile. Press Ctrl-C to interrupt Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://CrevaviWS2:50763/

SUMMARY

PARAMETERS

  • /rosdistro
  • /openni_node1/use_indices
  • /openni_node1/depth_registration
  • /openni_node1/image_time_offset
  • /openni_node1/depth_frame_id
  • /openni_node1/depth_mode
  • /openni_node1/debayering
  • /rosversion
  • /openni_node1/projector_depth_baseline
  • /openni_node1/rgb_frame_id
  • /openni_node1/depth_rgb_translation
  • /openni_node1/depth_time_offset
  • /openni_node1/image_mode
  • /openni_node1/shift_offset
  • /openni_node1/device_id
  • /openni_node1/depth_rgb_rotation

NODES / openni_node1 (openni_camera/openni_node) kinect_base_link (tf/static_transform_publisher) kinect_base_link1 (tf/static_transform_publisher) kinect_base_link2 (tf/static_transform_publisher) kinect_base_link3 (tf/static_transform_publisher) handdetector (hand_interaction/detectskelhands) ressetter (dynamic_reconfigure/dynparam) skel_tracker (skeletal_tracker/tracker)

auto-starting new master process[master]: started with pid [1019] ROS_MASTER_URI=http://localhost:11311

setting /run_id to 7cfb26b2-8555-11e1-975c-38607793109f process[rosout-1]: started with pid [1035] started core service [/rosout] process[openni_node1-2]: started with pid [1047] process[kinect_base_link-3]: started with pid [1048] process[kinect_base_link1-4]: started with pid [1049] process[kinect_base_link2-5]: started with pid [1050] process[kinect_base_link3-6]: started with pid [1057] process[handdetector-7]: started with pid [1061] process[ressetter-8]: started with pid [1068] process[skel_tracker-9]: started with pid [1077] Waiting for service /openni_camera/set_parameters... libusb couldn't open USB device /dev/bus/usb/001/014: Permission denied. libusb requires write access to USB device nodes. libusb couldn't open USB device /dev/bus/usb/001/014: Permission denied. libusb requires write access to USB device nodes. [ INFO] [1334313803.349585002]: [/openni_node1] Number devices connected: 1 [ INFO] [1334313803.349783723]: [/openni_node1] 1. device on bus 001:14 is a unknown (2ae) from unknown (45e) with serial id '' [ INFO] [1334313803.352306759]: [/openni_node1] searching for device with index = 1 [ INFO] [1334313803.410848582]: [/openni_node1] Opened 'unknown' on bus 1:14 with serial number '' [ INFO] [1334313803.424991158]: rgb_frame_id = '/openni_rgb_optical_frame' [ INFO] [1334313803.427352438]: depth_frame_id = '/openni_depth_optical_frame' New User 1 Lost user 1 New User 1 Lost user 1 New User 1 New User 2 Lost user 1 Lost user 2 New User 2 Lost user 2


Originally posted by narenayak on ROS Answers with karma: 3 on 2012-04-13

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Hi Nernayak,

When the program shows the message "looking for pose" you should go in front of the kinect sensor and pose like this:

image description http://3.bp.blogspot.com/-t9FxKt9JUts/TWfK4juSF7I/AAAAAAAABBI/36-uvouIG7I/s320/PsiPose.gif

Once the skeleton is calibrated you will be able to detect the hands.

Best regards, Martin.


Originally posted by Martin Peris with karma: 5625 on 2012-05-09

This answer was ACCEPTED on the original site

Post score: 3

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.