Rosanswers logo


The issue returns if the package is launched in superuser mode.

Hello all,

I have just installed ROS Indigo on my turtlebot PC having Ubuntu 14.04.02 which was just upgraded from Ubuntu 12. Earlier the turtlebot PC had Hydro. The problem I am describing hence was not present in the hydro installation.

On running,

roslaunch openni2_launch openni2.launch ,

I am getting the following error:

[ INFO] [1455122966.352999612]: Initializing nodelet with 4 worker threads.
[ INFO] [1455122968.132593659]: No matching device found.... waiting for devices. Reason: std::string openni2_wrapper::OpenNI2Driver::resolveDeviceURI(const string&) @ /tmp/binarydeb/ros-indigo-openni2-camera-0.2.5/src/openni2_driver.cpp @ 631 : Invalid device number 1, there are 0 devices connected.

I have tried the following solutions:

roslaunch freenect_launch freenect.launch : Does not work

https://github.com/turtlebot/turtlebot/issues/139 : Does not work

I also tried installing all sorts of drivers for the Kinect on turtlebot. The kinect works on other software giving me RGB as well as Depth sensing but still gmapping or any node requiring Kinect is ROS does not work probably because ROS Indigo uses OpenNi2 and not the driver I tested my kinect.

Thanks for the read.


I just got hold of this page regarding migration of turtlebot from Hydro to Indigo


Though I have set up the environment variable export TURTLEBOT_3D_SENSOR=kinect in my ~/.bashrc file, I do not know how to update to the new driver and get any calls from the existing ROS packages like gmapping to stop looking for OpenNI2.


Should I do a source install because the deb install is still calling OpenNi2 drivers instead of Freenect for Kinect?

Is there a way to substitute OpenNI2 drivers with freenect, or any working driver in turtlebot_navigation package.

Originally posted by arttp2 on ROS Answers with karma: 123 on 2016-02-10

Post score: 0

Original comments

Comment by jacksonkr_ on 2016-02-11:
Are you trying to use rgbdslam on the turtlebot? Does freenect-regview work for you? You can download it with sudo apt-get install libfreenect-lib

Comment by arttp2 on 2016-02-11:
I had already installed using sudo apt-get install freenect and the above command gives the output Unable to locate package libfreenect-lib. I tried to launch roslaunch turtlebot_navigation gmapping_demo.launch and this calls OpenNI2 not freenect, hence installing it did not help.

Comment by Orhan on 2016-02-11:
Have you tried this: sudo apt-get install --reinstall ros-indigo-openni-camera ros-indigo-openni-launch ?

Comment by arttp2 on 2016-02-11:
Reinstalling drivers helped. It does not show the OpenNI driver error now. But it shows some other warnings and errors that also came up when I was testing with the freenect. Nevertheless, gmapping works fine as seen in rviz. Thanks for the answer.

Comment by Orhan on 2016-02-19:
You should ask a new Question for your update.


1 Answer 1


Rosanswers logo


sudo apt-get install --reinstall ros-indigo-openni-camera ros-indigo-openni-launch

Originally posted by Orhan with karma: 856 on 2016-02-11

This answer was ACCEPTED on the original site

Post score: 1

Original comments

Comment by arttp2 on 2016-02-11:
Thank you!


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.