Rosanswers logo

Hi! I am trying to launch move_base, but I am getting such messages:

  1. when launching it through launch file:
    ERROR: cannot launch node of type [move_base/move_base]: can't locate node [move_base] in package [move_base]
  2. when launching it by rosrun:
    [rosrun] Couldn't find executable named move_base below /opt/ros/indigo/share/move_base [rosrun] Found the following, but they're either not files, [rosrun] or not executable: [rosrun] /opt/ros/indigo/share/move_base The system sees the package move_base, but there is no nodes in it. Other packages and nodes of navigation stack work fine. I use Ubuntu 14.04 virtual machine with ROS Indigo. I installed navigation stack with sudo apt-get install ros-indigo-navigation. My ROS_PACKAGE_PATH is /home/viki/catkin_ws/src:/opt/ros/indigo/share:/opt/ros/indigo/stacks I am very new to ROS, so I have no idea what caused the problem. Please, help me!

Originally posted by Dio Eraclea on ROS Answers with karma: 23 on 2015-04-14

Post score: 0


2 Answers 2


Rosanswers logo

It's not an answer but comment don't seem to work these days :s. Here are some leads to explore:

Can you see move base in the list when you run ls /opt/ros/indigo/lib/move_base/ ?
If not, this means that move base has not been properly installed. So try: sudo apt-get install ros-indigo-move-base
then you should see move base in /opt/ros/indigo/lib/move_base/ If yes, run rospack profile to update you package list and then you can try to run your node move_base again.

Hope this helps,

Originally posted by marguedas with karma: 3606 on 2015-04-14

This answer was ACCEPTED on the original site

Post score: 7

Original comments

Comment by Dio Eraclea on 2015-04-16:
Thanks for your answer! I can see move base in those folders. Actually, I fixed the problem, it was in the wrong settings in catkin workspace. After I reset the workspace and modified ROS_PACKAGE_PATH, all was working

Comment by wanglan on 2015-09-22:
hello! I met the same problem, can you tell me, what exactly do you do?

Comment by Dio Eraclea on 2015-09-29:
Actually, I do not remember exactly what I did. After that problem I reinstalled Ubuntu several times on different machines and I never got this problem again. I think, that you should look at setting catkin workspace tutorial on roswiki

Comment by M@t on 2016-05-23:
I had a similar problem where move_base was not installed (if in doubt type "rospack find move_base" into terminal and it should return the file path if its installed). Running "sudo apt-get install ros-indigo-move-base" fixed the problem for me.

Comment by Mr Tai on 2021-04-07:
Thanks. I am ok, so i did't buld node "move_base"


Rosanswers logo

Running "sudo cp /opt/ros/indigo/lib/move_base/move_base /opt/ros/indigo/share/move_base" fixed the problem for me.

Originally posted by wuming with karma: 41 on 2016-06-07

This answer was NOT ACCEPTED on the original site

Post score: 4

Original comments

Comment by matwilso on 2017-10-07:
Confirmed. Had the same problem in kinetic and this fixed it! (replacing indigo with kinetic)

Comment by hassamsheikh1 on 2018-11-12:
does not work for me. but having same problem


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.