0
$\begingroup$

Rosanswers logo

Hello, I'm new in ROS. When I tried to run robot_localization package by this command: roslaunch robot_localization ekf_template.launch I have met this issue below:

ERROR: cannot launch node of type [robot_localization/ekf_localization_node]: Cannot locate node of type [ekf_localization_node] in package [robot_localization]. Make sure file exists in package path and permission is set to executable (chmod +x)

I had run these commands before that:

source devel/setup.bash

and

source /opt/ros/melodic/setup.bash

So can I fix it? Many thanks.

[UPDATE] When I used the command:

rosrun robot_localization ekf_localization_node

I got:

[rosrun] Couldn't find executable named ekf_localization_node below /home/swarm-robotics/catkin_ws/src/robot_localization


Originally posted by HieuPham on ROS Answers with karma: 3 on 2020-07-03

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

As per info in your question, you first ran

source devel/setup.bash

to source your workspace and then:

source /opt/ros/melodic/setup.bash

Which is the cause it's not working. First run

source /opt/ros/melodic/setup.bash

followed by sourcing your workspace and it should work if everything else is fine. Also, make sure you ran catkin_make in the workspace you have the package in.


Originally posted by parzival with karma: 463 on 2020-07-04

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by HieuPham on 2020-07-04:
Many thanks, In my case, if I ran 2 commands follow your guide, it not working but it's ok when I run only source devel/setup.bash When I ran catkin_make --pkg robot_localization again, it's working correctly. I think when I used catkin_make command previously, I make a few mistakes but I skipped it.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.