Rosanswers logo

After updating ROS groovy from .debs today, the following happens with our software setup:

Source groovy setup:

source /opt/ros/groovy/setup.bash

Output of "env | grep ROS":


sourcing a previously working setup.bash of a rosbuild workspace:

source setup.bash

results in the following output:

kohlbrecher@sk-i7:~/flor_repo/rosbuild_ws$ source setup.bash
bash: /share/rosbash/rosbash: No such file or directory
[rospack] Warning: ROS_ROOT=/share/ros is not a directory

Output of "env | grep ROS":


Any ideas what´s going on here? The rosbuild workspace is depending on a catkin workspace. I´ll try reinstalling our setup from scratch next, to see if that solves the problem.

/edit: Tried installing from scratch using our install scripts and these also do not work anymore.

/edit: Related Q/A here

Originally posted by Stefan Kohlbrecher on ROS Answers with karma: 24361 on 2013-10-02

Post score: 11

Original comments

Comment by dornhege on 2013-10-02:
Does it help to rosws regenerate the setup.bash?

Comment by dcconner on 2013-10-02:
rosws regenerate did not help in my case; I'm seeing the same issue

Comment by Calder on 2013-10-02:
I'm seeing this problem too. Since ROS_ROOT has changed from the correct value of /opt/ros/groovy/share/ros to /share/ros, all tab-completion fails because they rely on rosbash (which needs ROS_ROOT set properly).

As a very temporary fix, you can export ROS_ROOT=/opt/ros/groovy/share/ros and it appears to fix the problem.

On systems sourcing a Catkin workspace, this problem can be fixed by running catkin_make in the workspace. This will set ROS_ROOT correctly.

Comment by barcelosandre on 2013-10-02:
I did it! I'm just waiting for an oficial solution!

export ROS_ROOT=/opt/ros/groovy/share/ros

export ROS_ETC_DIR=/opt/ros/groovy/etc/ros

Thank you!

Comment by mboulet on 2013-10-03:
I had to delete the workspace devel folder and then run catkin_make to fix the problem for me.


1 Answer 1


Rosanswers logo

The solution is delete your "devel" and "build" directories, then make a "catkin_make". It will solve the problem.

Originally posted by barcelosandre with karma: 168 on 2013-10-03

This answer was ACCEPTED on the original site

Post score: 11

Original comments

Comment by Martin Peris on 2013-10-03:
yup, regenerating "devel" and "build" on my workspace did the trick. Thanks!

Comment by mortenpj on 2013-10-13:
Solved my problem, thanks!


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.