0
$\begingroup$

Rosanswers logo

Hi All I am using rosbag play --clock myrecod.bag to play file and subscribe these three topics: "/camera/rgb/image_color", "/camera/depth/image", "/camera/depth/camera_info" and I want to process each frame of these topics by fovis (http://code.google.com/p/fovis/).my recording file is 20 fps and I have time-consuming calculation on each frame of data. There for I only able to subscribe 4 fps of my recordings.

How can I slow down the play back speed of my recordings file in order to get all frames?

Thanks in Advance Ramin


Originally posted by raminzohouri on ROS Answers with karma: 26 on 2012-10-22

Post score: 3

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Use the -r or --rate parameter of rosbag play.


Originally posted by Thomas D with karma: 4347 on 2012-10-22

This answer was ACCEPTED on the original site

Post score: 14


Original comments

Comment by raminzohouri on 2012-10-22:
Thank you Thomas I set rate value to 0.1 and now its working well and I am able to capture all the frames.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.