Rosanswers logo

Hello everyone.

I am running Diamondback installed via apt-get on Ubuntu 10.10. I installed the hokuyo_node (laser drivers package via apt-get) and connected my Hokuyo 04LX-UG01 to the machine.

While starting the hokuyo_node as indicated by the tutorial, and looking at the output in RViz, I only see one straight red line of points. The line doesnt move if I rotate or move the camera around. This behaviour is the same, independent if I start Rviz with: "rosrun rviz rviz -d rospack find hokuyo_node/hokuyo_test.vcg" or just as "rosrun rviz rviz" and using a custom tf base link to laser broadcaster.

I forgot to say that if I move my hand near the laser, the points do move and disappear, making the line shorter or larger, but always on 1 dimension.

EDIT: Even if I change the view to FPS or Orbit and move the camera around, the line stays at the same size and position.

Here is an image of the RViz window for clarity.

RViz Output http://hevia-koch.cl/rviz%20hokuyo.png

Originally posted by Pablo Hevia-Koch on ROS Answers with karma: 55 on 2011-04-12

Post score: 0


1 Answer 1


Rosanswers logo

I notice you have "TopDownOrtho" selected as view option. Does anything change if you switch to "fps" or "orbit" mode and move the view around? "TopDownOrtho" uses orthographic projection and only lets the camera rotate around the z-axis, which could lead to the described behavior.

Originally posted by Stefan Kohlbrecher with karma: 24361 on 2011-04-12

This answer was ACCEPTED on the original site

Post score: 1

Original comments

Comment by Stefan Kohlbrecher on 2011-04-12:
Ok, other things you could try is wether simulated laser scanners work (e.g. try out a erratic_robot in gazebo or similar) and of course looking at the laser scan using rostopic echo (pretty unlikely though that the scans themselves are faulty).

Comment by Pablo Hevia-Koch on 2011-04-12:
Nope, it doesn't. The grid moves and rotates, but the red points do not. Even in FPS or Orbit, the line stays the same size and position. Thanks for the input.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.