0
$\begingroup$

Rosanswers logo

Hi all,

I've been working with ROS for about 1.5 year now. I've just upgraded from Diamondback to Electric and everything seemed to be working fine, even rviz was still working. Today rviz started having a segmentation fault at launch.

I've tried to look for similar errors on the web and tried a few solutions, but haven't got it to work yet.

Output of rviz launch (sorry, but couldn't get it as a bullet points...):

freek@freek:~$ rosrun rviz rviz -l 
[ INFO] [1317359486.500866894]: rviz revision number 1.6.4 
[ INFO] [1317359486.500952896]: ogre_tools revision number 1.6.2 
[ INFO] [1317359486.500971041]: compiled against OGRE version 1.7.3 (Cthugha)
[ INFO] [1317359486.555935684]: Loading general config from [/home/freek/.rviz/config] 
[ INFO] [1317359486.556150849]: Loading display config from [/home/freek/.rviz/display_config] 
[ INFO] [1317359486.610373794]: RTT Preferred Mode is PBuffer. 
[ INFO] [1317359486.972239772]: Texture for pass 0: creating with size 1 x 1 
[ INFO] [1317359486.980397155]: Texture for pass 1: creating with size 1 x 1 
[ INFO] [1317359487.161710770]: RTT Preferred Mode is PBuffer. Segmentation fault (core dumped)

As you can see I've got the core file (memory dump) as well, but can't upload it here. I've tried setting the RTT mode to either Copy or FBO but this doesn't solve the issue. I've also got the .Ogre file if anyone is interested.

I'm running Ubuntu 10.10 and have the latest nvidia (Quadro FX880M) drivers installed:

freek@freek:~$ glxinfo |grep version
server glx version string: 1.4
client glx version string: 1.4
GLX version: 1.4
OpenGL version string: 3.3.0 NVIDIA 280.13
OpenGL shading language version string: 3.30 NVIDIA via Cg compiler

Any help is welcome :)


Originally posted by Freek on ROS Answers with karma: 31 on 2011-09-29

Post score: 3

$\endgroup$

5 Answers 5

0
$\begingroup$

Rosanswers logo

I just had the same issue. I fixed it by editing the .rviz/display_config file that rviz was using by default. I basically just deleted most of it, and then rviz launched sucessfully.


Originally posted by Dave with karma: 66 on 2011-09-30

This answer was ACCEPTED on the original site

Post score: 4


Original comments

Comment by Asomerville on 2011-11-03:
Freek, please mark this as the solution if it worked for you.

Comment by Freek on 2011-10-05:
This solved the issue for me as well! Thank you, can't believe I didn't try this :)

Comment by Freek on 2011-10-03:
I will try this today or tomorrow, will let you know. Thanks

$\endgroup$
0
$\begingroup$

Rosanswers logo

I get the same error (running Ubuntu 10.4, electric), but with the following added when I try to run rviz a second time:

The program 'rviz' received an X Window System error. This probably reflects a bug in the program. The error was 'BadDrawable (invalid Pixmap or Window parameter)'. (Details: serial 22 error_code 9 request_code 136 minor_code 3) (Note to programmers: normally, X errors are reported asynchronously; that is, you will receive the error a while after causing it. To debug your program, run it with the --sync command line option to change this behavior. You can then get a meaningful backtrace from your debugger if you break on the gdk_x_error() function.)


Originally posted by Paul0nc with karma: 271 on 2011-10-02

This answer was NOT ACCEPTED on the original site

Post score: 1


Original comments

Comment by emerson on 2011-10-20:
i have the same question,i don't know how

Comment by akargol on 2011-10-10:
I received this error from rviz once too. Restarting my computer solved the problem, but that is not a particularly desirable solution as I still have no idea what caused the original error.

$\endgroup$
0
$\begingroup$

Rosanswers logo

I had a similar issue (segfault at start-up). After deleting my personal configuration files in ~/.rviz i got it to work.

There was a bug earlier caused by doing this, but it is marked as fixed now. Warning: You do lose your topic subscriptions and window settings by doing this though.


Originally posted by Daniel Canelhas with karma: 465 on 2011-11-03

This answer was NOT ACCEPTED on the original site

Post score: 4

$\endgroup$
0
$\begingroup$

Rosanswers logo

I just got this problem as well. I use 10.4 and electric:

user@ubuntu:~/.rviz$ rosrun rviz rviz
[ INFO] [1321935622.778521758]: rviz revision number 1.6.6
[ INFO] [1321935622.778786716]: ogre_tools revision number 1.6.2
[ INFO] [1321935622.778826499]: compiled against OGRE version 1.7.3 (Cthugha)
[ INFO] [1321935622.887818975]: Loading general config from [/home/user/.rviz/config]
[ INFO] [1321935622.888264749]: Loading display config from [/home/user/.rviz/display_config]
[ INFO] [1321935622.966972423]: RTT Preferred Mode is PBuffer.
[ INFO] [1321935623.281105694]: Texture for pass 0: creating with size 1 x 1
Segmentation fault

I tried to remove lines in display_config - it didn't help. I removed both configs - got same results. Few times I had different error which actually did come up here as well:

user@ubuntu:~/.rviz$ rosrun rviz rviz -d 'rospack find turtlebot_interactive_markers'/config/interactive_markers.vcg 
[ INFO] [1321935611.525499608]: rviz revision number 1.6.6
[ INFO] [1321935611.525703015]: ogre_tools revision number 1.6.2
[ INFO] [1321935611.525739543]: compiled against OGRE version 1.7.3 (Cthugha)
[ INFO] [1321935611.639785830]: Loading general config from [/home/user/.rviz/config]
[ INFO] [1321935611.640200506]: Loading display config from [/home/user/.rviz/display_config]
[ INFO] [1321935611.700409981]: RTT Preferred Mode is PBuffer.
The program 'rviz' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadDrawable (invalid Pixmap or Window parameter)'.
  (Details: serial 21 error_code 9 request_code 55 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Any ideas (other than remove files)? Thanks.


Originally posted by Roman Burdakov with karma: 131 on 2011-11-21

This answer was NOT ACCEPTED on the original site

Post score: 2


Original comments

Comment by tfoote on 2011-11-21:
@Roman Burdakov this is a different error you should ask a different question.

$\endgroup$
0
$\begingroup$

Rosanswers logo

Hi all,

I spent a load of time fixing these issues. What I realised is that Virtualbox is being a nasty little rascal with it's 3d Acceleration.

Switching if off fixed these issues for me.

  1. Switch off your VM
  2. Just go to the VM Settings -> Display -> Uncheck Enable 3D Acceleration.
  3. Start your VM again.
  4. Rejoice!

Originally posted by sachitv with karma: 51 on 2017-04-16

This answer was NOT ACCEPTED on the original site

Post score: 3


Original comments

Comment by viveksudani on 2018-02-05:
Hey sachitv , Thanks for solution. This is worked for me

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.