0
$\begingroup$

I tried to solve below question by Edx course. One part of the requirement was to assign frames and find the DH parameters of the given robot manipulator. I assigned the x and z axis as below and find the DH parameters like that: enter image description here

enter image description here

I think I assigned axis correctly. Especially X2, because this one that make the problem. X2 can be both like in the picture and also upward, because in both of them it is perpendicular to both Z2 and Z1. However, when I did like that the answer became wrong. However, when I took the X2 as upward, the answer became correct. It is interesting for me, why X2 has to be upward while it also can be like in the picture I showed? Thank you very much :)

| improve this question | | | | |
$\endgroup$
0
$\begingroup$

When assigning the $x_i$ axis, it doesn't just have to be perpendicular to $z_i$ and $z_{i-1}$, it should be along their common normal (and pointing from $z_i$ to $z_{i-1}$).

In the case of $x_2$, $z_2$ and $z_1$ do not have a unique common normal since they are parallel so the exact placement of the origin of frame 2 and the $x_2$ axis is not fixed - imagine a vertical line that intersects $z_2$ and $z_1$ but can move along the $z_2$ (and $z_1$) axis a bit like a trombone (that's what it makes me think of anyway). You would normally want to put the origin in such a place to produce the most zeros in the DH table which is where you have it currently.

So $x_2$ should indeed be pointing upwards to be consistent with the DH convention.

| improve this answer | | | | |
$\endgroup$
  • $\begingroup$ Now I understood. Thank you very much :) $\endgroup$ – BHOS Apr 5 at 4:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.