0
$\begingroup$

I am programming my Create 2 with Arduino Uno. It worked fine a few weeks ago, then I just left it there, charging it about once a week. Now when I try to play with it again, I find that it starts to send weird sensor data.

For example, the value of light bumper data (package ID 45) supposes to be within the range of 0-127. It used to be fine. But now I receive 254 when there is no obstacle in front of the robot. Same issue happens to many different sensor readings.

Can someone help me with this problem?

$\endgroup$
  • $\begingroup$ Welcome to Robotics, SichaoSong. What are you getting for the intensities (packages 46-51)? What code are you using? Are the sensors dirty? What troubleshooting have you done so far to solve your problem? $\endgroup$ – Chuck Jul 11 '17 at 13:06
  • $\begingroup$ I did not change the code. It worked pretty fine 2 weeks ago (receiving correct data). I only request package 45 to decide whether there is an obstacle in front of the Roomba. The sensors should be clean (I will clean it anyway). Moreover, the same issue happens to other data readings. For example, package 21 gives 254 when the charging state is Not Charging (should be 0). I will try to reset the Roomba to see whether this can solve the issue. $\endgroup$ – Sichao Song Jul 12 '17 at 10:57
  • $\begingroup$ I am also trying to control the create with an Arduino. Although it works some of the time, at other points communication between the Arduino and Roomba does not work. I have the Arduino powered using a 9V battery and using ports 3 and 4 (TX and RX) I have connected the Roomba with the Arduino. I set the baud to 9600 before any testing by pressing the clean button and waiting for the tone. Is this how you connected your Roomba? I have tested my own code many times and other tutorials as well, so I want to ensure this isn't some other obscure connection issue. $\endgroup$ – Stanley Jul 26 '17 at 17:45
2
$\begingroup$

Try to reset your Create 2:

Send a 7 via the serial port to reset it.

OR

Press and hold Dock and Spot on the robot for 10 seconds. When the button is released, Roomba will play the reset tone.

This helped me once when I had problems with the serial interface.

Keep in mind that the baudrate will be reset to 115200.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.