0
$\begingroup$

I got this error while trying to install ros2 humble:

Err:6 http://packages.ros.org/ros2/ubuntu mantic Release
  404  Not Found [IP: 140.211.166.134 80]
Reading package lists... Done                 
E: The repository 'http://packages.ros.org/ros2/ubuntu mantic Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
$\endgroup$

1 Answer 1

2
$\begingroup$

ROS 2 Humble is not supported as a binary distribution on Ubuntu Mantic (23.10)

In general, when you run into issues like this, it is important to check what the supported platforms are for a given ROS 2 distribution. All of these are documented in REP 2000. More specifically, in this case, you would want to consult the section for Humble Hawksbill.

As a rule of thumb, ROS binary packages are available for the current LTS that was available at the release of that ROS distribution.

  • Crystal Clemmys (December 2018 - December 2019) - Ubuntu Bionic (18.04)
  • Dashing Diademata (May 2019 - May 2021) - Ubuntu Bionic (18.04)
  • Eloquent Elusor (November 2019 - November 2020) - Ubuntu Bionic (18.04)
  • Foxy Fitzroy (May 2020 - May 2023) - Ubuntu Focal (20.04)
  • Galactic Geochelone (May 2021 - November 2022) - Ubuntu Focal (20.04)
  • Humble Hawksbill (May 2022 - May 2027) - Ubuntu Jammy (22.04)
  • Iron Irwini (May 2023 - November 2024) - Ubuntu Jammy (22.04)
  • Jazzy Jalisco (May 2024 - May 2029) - Ubuntu Noble (24.04)

Rolling is in the process of being migrated to Noble to support the Jazzy release.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.