Rosanswers logo


I have a world in gazebo(fuerte) with turtlebot in it and I have the map of the world too. After launching the world, when I try to launch the launch file described below, I get this warning:

[ WARN] [1366190909.527997203, 40.084000000]: Waiting on transform from /base_link to /map to become available before running costmap, tf error:

Launch File:

<!-- Run the map server -->
  <arg name="map_file" default="$(find turtlebot_navigation)/maps/willow-2010-02-18-0.10.yaml"/>
  <node name="map_server" pkg="map_server" type="map_server" args="$(arg map_file)" />

  <!--- Run AMCL -->
  <include file="$(find turtlebot_navigation)/config/amcl_turtlebot.launch" />

  <!--- Run Move Base -->
  <include file="$(find turtlebot_navigation)/config/move_base_turtlebot.launch" />


I made the map of the environment with a turtlebot when I was using electric and I never used to get this warning in electric. After running this launch, when I do rosrun tf view_frames, /map frame does not show up in the list of frames at all. I referred to the following questions, but I am not able to get the catch. http://answers.ros.org/question/35844/help-with-navigation-error-transform-from-base_link-to-map/ http://answers.ros.org/question/9928/transform-from-base_link-to-map-navigation-stack-error/

What is the problem here ? Is there file I have to edit before running the launch or am I missing a step ?


image description

This is my TF tree (Pls save the image and zoom in for a clearer picture).

@Procópio Silveira Stein, I cannot visualise any data on rviz and I am unable to choose the initial pose in rviz. /map frame does not seem to exist at all.

I will try few more tricks and update shortly. Thanks,


Originally posted by prasanna.kumar on ROS Answers with karma: 1363 on 2013-04-17

Post score: 0

Original comments

Comment by prasanna.kumar on 2013-04-17:
I did not understand your question properly. I guess map_server node is publishing the /map frame.

Comment by Procópio on 2013-04-17:
Sorry, I had some typos. As I told, I am not familiar with Gazebo. When using Stage, I think I had to choose an Initial Pose from Rviz to have AMCL started. Can you post an image of your TF tree, using "rosrun tf view_frames" , please?


1 Answer 1


Rosanswers logo

I found the solution today, after 3 days. Actually, it was a bit annoying when I realized it. Here's the scoop.

In electric after launching gazebo-gui, I hade to run rosrun nodelet nodelet manager __name:=openni_manager before launching the AMCL and rviz but with fuerte that step was un-necessary till fuerte version 1.8.10. But in version 1.8.11 of fuerte the openni_manager nodelet is needed again. The AMCL stopped printing the warning immediately after I ran the openni_manager.

It's solved but I really want to know why things are so erratic!

Originally posted by prasanna.kumar with karma: 1363 on 2013-04-18

This answer was ACCEPTED on the original site

Post score: 1

Original comments

Comment by Procópio on 2013-04-19:
I'm happy you managed to find a solution. cheers


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.