1
$\begingroup$

I am trying to import my xacro model like it's shown in the https://github.com/cyberbotics/webots_ros2/wiki/Tutorial-Ros2Supervisor-Import-your-Urdf-Robot tutorial, changing only the xacro and world file, however I can launch the project but the robot does not appear in the webots simulation, only the world does, my terminal says : "WARNING: the Ros2Supervisor was not able to spawn this URDF robot" and nothing more, I can't see what I have done wrong as I changed almost nothing... I'm not sure if I'm missing tags in my urdf xacro file as I also tried using one in the tutorials (humble urdf tutorial - 07-physics.urdf) that should be good but the problem still occurs. Thanks ! I'm using Webots R2023a, ros2 humble, on VirtualBox Ubuntu

$\endgroup$

1 Answer 1

0
$\begingroup$

First of all, I have updated the linked tutorial to the most recent version of the package. The Ros2Supervisor is not spawned the same way as it was in previous versions of the package. Also, I opened a Pull Request on the repository to restrict the message "WARNING: the Ros2Supervisor was not able to spawn this URDF robot" as it was always triggered, even if the URDF is correctly spawned. If you want to benefit from this change, although it is not mandatory, you can build the package from sources (master branch). More information is available in this tutorial. In any case, you should use the 2023.0.2 version of the package, which is the latest stable binary release on Humble.

Getting back to your issue, it is weird that you don't get any other error messages. The Ros2Supervisor node should provide information on why the URDF could not be spawned. Are you able to launch the universal robot example?

ros2 launch webots_ros2_universal_robot multirobot_launch.py

If you still encounter the issue after updating the launch file to the new version of the tutorial, you can post the content of your files so that I can investigate further.

Disclaimer: I am a Webots developer working at Cyberbotics.

$\endgroup$
2
  • $\begingroup$ Thank you very much, the updated tutorial made it work ! I have built the package from source but I still get the Warning before it executes the spawning well (It seems it's still using my former webots2023 version, not the one I built, not sure where I should point the WEBOTS_HOME variable to), Thanks a lot! $\endgroup$ Apr 11, 2023 at 10:47
  • $\begingroup$ The change is not merged yet. Once the PR is merged to master, you will be able to benefit from the update. Cheers! $\endgroup$ Apr 11, 2023 at 11:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.