Rosanswers logo

I am using the rosrun on Nvidia Ubuntu 14.04 platform and i have USB Camera ( UVC Complaint ), i ran the following,

roscore rosrun libuvc_camera camera_node

It worked fine, then i started installing the other components like kinect, stereo camera drivers ( some more components )

after that it stopped working,

root@tegra-ubuntu:/home/ubuntu# rosrun --debug libuvc_camera camera_node

[rosrun] Looking in catkin libexec dirs: /opt/ros/indigo/lib/libuvc_camera

[rosrun] Looking in rospack dir: /opt/ros/indigo/share/libuvc_camera

[rosrun] Searching for camera_node with permissions /111

[rosrun] Running /opt/ros/indigo/lib/libuvc_camera/camera_node

[ INFO] [1474173238.408420389]: Opening camera with vendor=0x0, product=0x0, serial="", index=0 uvc_start_iso_streaming: Busy (-6)

before running this command, i have two video nodes video0 & video1 and i could able to see both videos using luvcview.

After i ran this command, i got only the video0 only ( also it seems that earlier video1 node becomes video0 )

Please share your inputs

Originally posted by Hariharan Veerappan on ROS Answers with karma: 1 on 2016-09-17

Post score: 0

Original comments

Comment by gvdhoorn on 2016-09-18:
Please use the Preformatted text button to format console copy/pastes. It's the on with 101010 on it.



1 Answer 1


Rosanswers logo

I have met this issue too. And, I found that, if i uninstall "compressed-image-transport", then it works again. But, I still don't know how to resolve it without uninstalling "compressed-image-transport".

Originally posted by DanielLiu with karma: 16 on 2016-10-31

This answer was ACCEPTED on the original site

Post score: 0


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.