Rosanswers logo

Hi, I have camera connected through firewire:

$ lsfirewire
fw0: Linux Firewire Juju
fw1: Point Grey Research Flea2 FL2G-50S5C

However, when I try to run camera1394_node I get:

$ rosrun camera1394 camera1394_node 
[ERROR] [1351859527.447323402]: [camera] device open failed: [Camera1394::open]: No cameras found

I have tested the camera on another machine and it worked without problems. This machine does not have graphical interface so coriander is not an option here.

Originally posted by liborw on ROS Answers with karma: 801 on 2012-11-02

Post score: 0

Original comments

Comment by joq on 2012-11-02:
Did camera1394_node work on the other machine?

Comment by liborw on 2012-11-04:
Yes, it works.


1 Answer 1


Rosanswers logo

So far, there is no evidence of a ROS driver problem. The Flea 2 is known to work with camera1394, and your camera works with it on another system.

You may be able to run coriander (slowly) on a system with a display by using a remote X connection.

If that does not work and presuming the driver and the camera do work, the next step is to check the stuff in the middle.

  • Is the 1394 cable working? Maybe try a different one.

  • Is the 1394 host adapter on your headless system good? Apparently it found the device, but there could still be troubles actually talking to it.

  • Is this kernel firewire driver identical to the one on the system that worked? (Probably OK, Juju is the latest firewire driver for Linux.)

Originally posted by joq with karma: 25443 on 2012-11-06

This answer was ACCEPTED on the original site

Post score: 0


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.