0
$\begingroup$

Rosanswers logo

The definition for ROS_INFO_STREAM_THROTTLE looks like (question valid for all ROS_**_THROTTLE rosconsole macros ):

#define ROS_INFO_STREAM_THROTTLE(rate, args) ......

However, if i put ROS_INFO_STREAM_THROTTLE( 10, "whatever" ) it will be printed every 10 seconds. If i put ROS_INFO_STREAM_THROTTLE( 0.1, "whatever" ) it will be printed 10 times a second. So unlike ros::Rate where rate means actions per second the macro arg rate here means seconds between the actions. So it is more of a timeout, isn't it? Should maybe it should be renamed like

#define ROS_INFO_STREAM_THROTTLE(rate, args) ......

??

Do you think that would be clearer to the users of the marco?


Originally posted by Wolf on ROS Answers with karma: 7555 on 2014-12-23

Post score: 0


Original comments

Comment by gvdhoorn on 2014-12-23:
I think you meant to say #define ROS_INFO_STREAM_THROTTLE(period, args) or something similar? Your 'renamed' statement is now identical to the original one.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

That does look confusing/misleading, period does sound more accurate. it's probably worth a ticket to update the documentation/prototype.


Originally posted by tfoote with karma: 58457 on 2014-12-29

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.