0
$\begingroup$

I am trying to follow the Getting Started page on the nav2 docs but whenever I try to set a Nav2 Goal, I get this error:

[rviz2-5] Start navigation [rviz2-5] [INFO] [1707599559.489378660] [rviz_navigation_dialog_action_client]: NavigateToPose will be called using the BT Navigator's default behavior tree. [rviz2-5] [ERROR] [1707599559.489864143] [rviz_navigation_dialog_action_client]: Goal was rejected by server

I am on Ros2 Humble and have gone through the installation and sourcing steps. I also changed robot_model_type: "differential" to robot_model_type: "nav2_amcl::DifferentialMotionModel" in waffle.yaml.

In the Navigation 2 panel in RViz, it shows that Navigation is inactive, but Localization is active. Do I need to somehow activate Navigation?

Image of RViz with Navigation: inactive, Localization: active

$\endgroup$

1 Answer 1

0
$\begingroup$

Hi did you install all dependencies for this tutorial?

sudo apt-get install ros-humble-nav2*

sudo apt-get install ros-humble-turtlebot3*

sudo apt-get install ros-humble-navigation2

sudo apt-get install ros-humble-nav2-bringup

sudo apt-get install ros-humble-tf2*

Finally, you need to export the path to your bash and locate the turtlebot3 model (link gazebo-rviz2):

source /opt/ros/humble/setup.bash
export TURTLEBOT3_MODEL=waffle
export GAZEBO_MODEL_PATH=$GAZEBO_MODEL_PATH:/opt/ros/humble/share/turtlebot3_gazebo/models

Always source the workspace or root ros2 packages

It should work.

why did you change the "differential" to "nav2_amcl::DifferentialMotionModel"? Is it not the same? Anyway, if you changed you must "colcon build" the workspace and source it again...

$\endgroup$
2
  • $\begingroup$ I ran the installation commands but I am still getting the same error as before. I changed "differential" to "nav2_amcl::DifferentialMotionModel" because I was following a Nav2 tutorial video and was told to do so. Also, I am not currently in a workspace. I am just running the launch command in my home directory. Do I need to create a ros workspace? $\endgroup$
    – Michael
    Commented Feb 10 at 23:09
  • $\begingroup$ I don't believe it's a requirement. The planner is not accepting your goal pose. Usually this issue raises when the goal is out of costmap boundaries (too far from laser readings). However you are just running a tutorial. Therefore I conclude you have an issue within the planner type you are trying to use or this kinematics plugin you have modified. Try to use just "differential". Or restart tutorial by scratch (remove pkgs, maybe reinstall ROS2), did you try? $\endgroup$ Commented Feb 11 at 12:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.