Skip to main content
2 votes

Hello, when I run rosdep update, i get 'timed out'

While following the ROS2 humble tutorial, I faced the same challege. I tried running the sudo rosdep init followed by ...
MosesChuka's user avatar
2 votes

Find all dependencies of a ROS 2 workspace for a source build

I'm in a similar situation. I haven't found a comprehensive way to quickly generate a .repos file from my dependencies for example, but colcon graph definitely ...
clemfandango's user avatar
1 vote
Accepted

I am trying to build a ROS/moveit catkin workspace and I get the error Could not find a package configuration file provided by "moveit_visual_tools"

I would proceed by installing the package, which causes the error: sudo apt-get install ros-melodic-moveit-visual-tools
Jakub Ivan's user avatar
1 vote
Accepted

ROS2 Error while installing dependencies (rosdep)

I fixed that issue by modifying the file /usr/lib/python3.11/site-packages/rospkg/os_detect.py, by importing platform as distro, i.e. the new imports of that file ...
enf's user avatar
  • 21
1 vote

I get this error E: Unable to locate package ros-humble-gazebo-ros2-control while trying to setup rosdep in my raspbery pi 4 Model B

Gazebo is not available on arm64 so dependencies of gazebo including ros-humble-gazebo-ros2-control are not going to be available on arm64 either. You can try ...
Tully's user avatar
  • 25.1k
1 vote
Accepted

Installing xtensor package for building Navigation2 from Source for ROS2-Humble, on Ubuntu Focal (20.04)

You will need to install xtensor on 20.04 from source, it is not available in apt and one of many reasons MPPI isn't available in any ROS distributions supporting ...
Steve Macenski's user avatar
1 vote
Accepted

rosdep key for SDL2 not working

You found the right entry. However you should be referencing the parent key, not the platform specific package. So sdl2 and then on your platform rosdep will ...
Tully's user avatar
  • 25.1k
1 vote
Accepted

Rosdep installing python dependencies as root seems to break the installation

I should have added --as-root pip:false as an extra argument to rosdep. This is described at github.
Arnold's user avatar
  • 111
1 vote
Accepted

bloom: Generate debian package with pip-only dependency?

As is stated in the rosdep contributing guide " Native packages are strongly preferred. (They are required for packaging and have upgrade and conflict tracking.)" As per the answer to the ...
Tully's user avatar
  • 25.1k

Only top scored, non community-wiki answers of a minimum length are eligible