Skip to main content

Questions tagged [vscode]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
1 vote
2 answers
42 views

How to resolve import error?

I created a simple publisher pkg to move around the turtle in turtlesim and getting this import error, let me know if you need any other information. Please correct me if I am doing anything wrong --&...
diysumit's user avatar
-2 votes
3 answers
188 views

Import "rclypy" could not be resolvedPylancereportMissingImports [closed]

I am trying to follow a ros2 tutorial, and I have a test node working, it's an executable and runs as expected from the terminal. I am now trying to make the turtlesim node draw a circle. I have ...
carolinerooney's user avatar
0 votes
1 answer
109 views

How to add wiringPi library with cmake on vscode?

I tried a few things but I am not so knowlegable about it. I tried with cmakeLists.txt: ...
Jonathan Dawsa's user avatar
0 votes
0 answers
177 views

How to debug ROS 2 programs in vscode

I usually debug my ROS 2 programs using print statements and echoing to topics. Is there a better way to debug ROS 2 programs so that I can see the value of certain variables or even stop the program ...
Fer's user avatar
  • 1
0 votes
0 answers
74 views

VSCode + ROS 2 error squiggles stop working

I am using VSCode for ROS 2 development, and generally this works really well but every so often suddenly the error squiggles stop working, with following error message: ...
JRTG's user avatar
  • 2,074
0 votes
0 answers
31 views

ROS VS Code Debugger unrecognized remap tag in <include> tag

I am using ROS extension for VS Code and I have organized my launch files based on Roslaunch tips for large projects. I have 2 main launch files, one that I launch from the linux terminal, and one via ...
hunterlineage's user avatar