Questions tagged [vex]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0
votes
1answer
162 views

RobotC startMotor command useless?

I learned recently that robotc has a command called startMotor. it has two parameters, a motor and a speed, and it sets the motor to the speed. But the same thing can be accomplished in one line like ...
0
votes
0answers
14 views

Strange behavior from VEX claw assembly using servo command

I noticed something odd when I tried to loop a claw so it would just open and close (eventually I want to have it just open when the ultrasonic sensor detects something in front of it and close a ...
1
vote
0answers
21 views

Measuring torque of Vex gear shaft - highest accuracy for lowest price [closed]

I am seeking to collect data for my IB Physics IA (internal assessment). My question seeks to establish the relationship between speed and torque by adjusting gear ratios. (I am aware that gear ratios ...
2
votes
2answers
1k views

Is there an online RobotC IDE?

I'm on a Linux chromebook, and am using a Vex robot, and am wondering if there is an online IDE for RobotC that will run my computer?
1
vote
1answer
497 views

RobotC Code Malfuncion (VEX Robotics Clawbot)

I have a standard VEX Clawbot, which I've been trying to make go straight for some time. I've been following this guide: http://www.education.rec.ri.cmu.edu/products/cortex_video_trainer/lesson/3-...
1
vote
2answers
486 views

Robot won't work properly, claw will only go one way and will only open or close once per cycle

We're students trying to make a clawbot for a Science Seminar class. However, for some reason, whenever we try to move the arm or the claw in a certain way, it will lock up and only move that ...
1
vote
1answer
278 views

How can I switch between Autonomous mode and usercontrol?

I want to switch from usercontrol to autonomous. When I have the program running for 120 seconds, how come it wont automatically switch in autonomous mode? Thanks! ...
0
votes
1answer
350 views

VEX Cortex Motor Speeds up under load

I am trying to get my robot to drive straight and am having trouble. I find that when running the motors with no load they run fine. If I put a load on one motor it accelerates. The other performs ...
0
votes
1answer
248 views

What is the RobotC type for motors?

I'm trying to create a function that allows me to more easily start a motor, but I'm running into a problem, I don't know the type to use for the motorName argument....
1
vote
1answer
49 views

How to distribute tension load on a three footed claw?

Good day! I am helping my little ones 6 and 7 to develop a robot that can pick up and stack cubes three high as well as gather blocks. They came up with the design that enables them to pick up ...