Skip to main content
Share Your Experience: Take the 2024 Developer Survey

Questions tagged [uwsim]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
1 answer
2 views

could gmapping pkg work in UWSim?

Hey guys,I am trying to do path planning using UWSim + RViz.And now there's something wrong with mapping.I followed some tutorials which is implemented by Gazebo+RViz and I also get the necessary ...
user avatar
0 votes
1 answer
10 views

How to apply a path planning algorithm in UWSim

Anyone knows about how to develop your code on the platform of UWSim?I want to test my path planning algorithm in UWSim,like planning a pratical path from a start point to a goal position with ...
user avatar
0 votes
1 answer
6 views

LSD-SLAM virtual camera calibration

Hello, I have recorded some actions using $rosbag record within the virtual simulator called UWSim. I am trying right now to make it work with lsd_slam. My camera topic is /g500/camera1 Therefore, I ...
user avatar
0 votes
1 answer
1 view

Unknown noise in uwsim 3D range mapping

I am working with UWSim, and I have modelled a rotating multibeam on the AUV (like a lidar on a car) that maps the 3D surroundings of the robot, creating a "range map". I am facing a type of ...
user avatar
0 votes
1 answer
359 views

RViz doesn't load .dae mesh. Cannot locate it

I am trying to load an underwater robot mesh in RViz. Because I could not do this with a .osg file, I converted it to .dae with Blender. Even though I have done that, RViz is still not able to load it ...
user avatar
0 votes
1 answer
1 view

for uwsim, how can I create two currents?

For my project, I would like to make my scene in which two currents are generated in different directions. I thought having two oceanState tags would get this done, but it gave me an error. Any method ...
user avatar
0 votes
1 answer
1 view

set constant speed for AUV on dynamic uwsim

I want to set constant speed for AUV, however, uwsim is dynamic which means I am only able to give force to the AUV's thruster and the AUV is influenced by the water's friction force. If I could make ...
user avatar
0 votes
1 answer
3 views

uwsim: uwsimbenchmarks/GTpublish.h: No such file or directory

Hi i am trying to run the demo of pipe following for UWSIM http://www.irs.uji.es/uwsim/wiki/index.php?title=Let%27s_do_it:_Pipe_following I am running the line ...
user avatar
0 votes
1 answer
3 views

[solved] UWsim installscene.sh command not found

Hi, I just start with ROS and UWsim I am trying to install new scenes because i want to modified a scene for my project. I follow the guide on this answer http://answers.ros.org/question/234836/uwsim-...
user avatar
0 votes
1 answer
8 views

error when using catkin_make_isolated

I use command catkin_make_isolated in the terminal, error is shown below: ...
user avatar
0 votes
1 answer
1 view

UWsim gui doesnt start

I recently installed did a packaged based installation for the UWsim. But when I do rosrun Uwsim UWsim......it executes correcltly till the point where it starts printing [ INFO] [1465903418.261073092]...
user avatar
0 votes
1 answer
1 view

error when running executable file on UWSim

The example code is including three files which are header file, member function file and main file. And the code is copied from the textbook. ...
user avatar
0 votes
1 answer
2 views

Based on uwsim, is it possible to set the friction force of water for the auv?

Based on uwsim, is it possible to set the friction force of water for the auv? The auv would drift after the thruster was shut down. I want to set a friction force in order to make the auv stop ...
user avatar
0 votes
1 answer
2 views

Based on uwsim, what can I do to let the auv stop when pid was closed

I run the pid controller to let the auv moving to a setpoint. When it reached setpoint and pid controller was closed automatically, the auv still moved even though I give the thruster intput zero. I ...
user avatar
0 votes
1 answer
1 view

Why my computer suddenly need such a long time to start uwsim

Why my computer suddenly need such a long time to start uwsim? It could start uwsim very fast before. But now it needs over ten minutes. I used rosclean command but it is not helpful. I don't know why....
user avatar
0 votes
1 answer
15 views

URDF has inertia specified, apparently, but I can't find where

Hi, Am currently getting the following warning which I think is the cause of UWSim crashing if challenged by anything more than loading: ...
user avatar
0 votes
1 answer
4 views

pid for angle on uwsim

I run pid for angle on uwsim. I set ki=kd=0 which means P controller is implemented. There exists sustained oscillation. But after a period of time, the oscillation will decrease and the curve will be ...
user avatar
0 votes
1 answer
1 view

on uwsim, orientation from topic pose and topic imu is different. Why?

on uwsim, orientation from topic pose and topic imu is different. I set the initial yaw of auv as 0 by modifying yaml file. Quaternion from topic pose is x=0 y=0 z=0 w=1. Quaternion from topic imu is ...
user avatar
0 votes
1 answer
1 view

based on uwsim, the orientation z from imu is in the inverval from -0.6 to 0.99, what is the unit of these values

based on uwsim, the orientation z from imu is in the inverval from -0.6 to 0.99, what is the unit of these values. the unit is not degree Originally posted by ZYS on ROS Answers with karma: 108 on ...
user avatar
0 votes
1 answer
1 view

Error: the position x and y subscribing from topic "/g500/pose" and "/uwsim/girona_500/odom is still 0, and z is increasing

No mattter what the initial position I set, the position x and y subscribing from topic "/g500/pose" and "/uwsim/girona_500/odom is still 0, and z is increasing. But actually, I can see ...
user avatar
0 votes
1 answer
1 view

uwsim problem while installation in indigo

i tried the steps for installation on my ros-indigo as stated in this page http://www.irs.uji.es/uwsim/wiki/index.php?title=Installing_UWSim but , when i run rosrun uwsim uwsim this command . i am ...
user avatar
0 votes
1 answer
1 view

Problem for building long baseline navigation system on UWSim

Since the transponder is not available on UWSim, I replace it with AUV. My idea is to make the target AUV send acoustic signal to transponder AUV and measure the travelling time of acoustic signal so ...
user avatar
0 votes
1 answer
5 views

Error occurred when running command 'catkin_make_isolated --install'

Based on UWSim, I want to let a AUV contact with another AUV. Thus I want to make one AUV act as publisher and another one act as subscriber. I add talker.cpp and <...
user avatar
0 votes
1 answer
1 view

Launch file for UWSim problem. How do you write the node?

The below code portion works to launch the default UWSim node, but how do you alter it to open any other scene? ...
user avatar
0 votes
1 answer
4 views

UWSim: Simulating RADAR using Multibeam Sensor

I would like to simulate a radar sensor in UWSim environment. I know that it is somehow possible using the multibeam sensor facility, but I would like to get some ...
user avatar
0 votes
2 answers
1 view

How to define new topic in UWSIM?

Hello, I want to add a topic through which two vehicles can communicate with each other. Currently, the vehicles communicate to ROS and vice-versa. I want the vehicles to communicate with each other. ...
user avatar
0 votes
1 answer
1 view

UWSim multi robots with sensors

Hi, I am having issues setting up a scene with 2 robots, each equipped with an IMU. My scene XML looks like: ...
user avatar
0 votes
1 answer
1 view

Uwsim how to add Mass to terrain cirs_trident

Hi I am using UWSIM package. I loaded the CIRS scene. Everything is working fine. My problem is that the AUV passes through the wall of the terrain. I tried adding some mass to my terrain, but it sank ...
user avatar
0 votes
1 answer
2 views

Using UWSim GPS

Hello, I am a beginner user of UWSim and I was trying to use the GPS sensor. I run "rosrun uwsim uwsim" and the scene with the robot in a tank loads up. I notice that there is a topic "/...
user avatar
0 votes
1 answer
3 views

multi robots in uwsim

Hello, I tried to load two robots in environment, in order i put two tag with different position for them and also different topic for their navigation, but when i send data to topic of second robot, ...
user avatar
0 votes
1 answer
2 views

scale tag in uwsim

Hello, I want to use scale tag for my mesh file in urdf that is loaded in uwsim, i tried like standard urdf in mesh tag, but it doen't work, also tried with inside collision tag that i got parsing ...
user avatar
0 votes
1 answer
1 view

segmentation fault in running uwsim

Earlier uwsim was running well. Now it is showing segmentation error for last 3-4 days .. ...
user avatar
0 votes
1 answer
1 view

UWSim install problem, Ubuntu 12.04,ROS Groovy

Hi, I have some problems on using command "rosrun uwsim uwsim" to run uwsim following errors are showing: ...
user avatar
0 votes
1 answer
3 views

View from virtual camera in uwsim

How to get a view of an object from virtual camera in robot in uwsim?There is not much documentation for uwsim. So how to learn using it . Should i try to understand its coding first because that also ...
user avatar
0 votes
1 answer
1 view

Adding one more g500 in uwsim?

How to add 1 or more robots in uwsim ? Can we simply do it by editing cirs.xml ? Originally posted by Mind_hunter on ROS Answers with karma: 51 on 2014-08-11 Post score: 0
user avatar
0 votes
1 answer
2 views

uwsim_binary: error while loading shared libraries: libosgbCollision.so: cannot open shared object file: No such file or directory

This is a solved question. I want to make it public. After updating a lot of hydro packages, when I run: $ rosrun uwsim uwsim --disableShaders I obtained this: <...
user avatar
0 votes
1 answer
9 views

running UWSim commands in ROS

Where can I find a good documentation about the UWSim in ROS. Actually having the source files is not enough and it is actually hard to follow all the functions. for example, how can I use these ...
user avatar
0 votes
1 answer
1 view

After update UWSim only with --disableShaders

I have installed ROS Groovy and UWSim and everything was working fine. Next day Ubuntu "Update Manager" said there is cca 100 updates recommended and I updated everything. After that I can ...
user avatar
0 votes
2 answers
1 view

Rosmake UWSim error - 1 package failed

So, Im trying to install UWSim again. I also followed all tutorials but when I run rosmake UWSim after some time it says: ...
user avatar
0 votes
1 answer
1 view

ROS Answers SE migration: rosrun UWSim

Hy, i'm trying to run UWSim but when I type rosrun UWSim UWSim it shows me this: Warning: Failed to connect to host. Make sure 3D acceleration is enabled for this VM. [ INFO] [1364229036.589787181]: ...
user avatar
0 votes
1 answer
1 view

rosrun UWSim error

Hy, I have finally installed ros and UWSim. After completing "rosmake UWSim" it said 49/49 something finished with success. Than I entered in Terminal "rosrun UWSim UWSim" and this ...
user avatar
0 votes
2 answers
62 views

Missing resource

Hy, im trying to install UWSim but when I type rosdep install UWSim it shows me this: ERROR: Rosdep cannot find all required resources to answer your query Missing resource UWSim ROS path [0]=/opt/ros/...
user avatar
0 votes
1 answer
1 view

UWSim, Ubuntu 12.04, ros-fuerte installation problem

Hello, I am trying to install UWSim in Ubuntu 12.04 with fuerte installed. I checked out the repository from here ...
user avatar
0 votes
1 answer
1 view

ROS Fuerte snags on OSX Lion

So I think I was finally able to install ROS Fuerte on Mac which cannot easily be accomplished by following religiously the tutorial in there as it keeps on hitting snags. Here are some error ...
user avatar
0 votes
1 answer
3 views

UWSim install problem

I cannot get to install UWSim. I'm running it on Precise (12.04) I thought it might have something to do with the ROS_PACKAGE_PATH but since it seems correct I do not know what's up. Here's the deal: ...
user avatar
0 votes
1 answer
1 view

ROS Answers SE migration: osg missing?

Hi all! I'm trying to use UWSim and did eveything on the webpage. The problem now is that when I do: rosmake UWSim --rosdep-install I get the following error: [rosbuild] Including /opt/ros/...
user avatar
0 votes
2 answers
2 views

segmentation fault on running UWSim

UWSim; using osgOcean 1.0.1 Building scene... . Loading cubemaps: 0.340616s . Generating ocean surface: 0.000218s . Creating ocean scene: 0.000686s . Setting up lighting: 1.3e-05s . Setting localized ...
user avatar