Skip to main content
OverflowAI is here! AI power for your Stack Overflow for Teams knowledge community. Learn more

Questions tagged [turtlebot-bringup]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
2 answers
131 views

Problem when launching nav2_bringup with your own param file

I am encountering issues when attempting to pass my own parameter file while launching nav2_bringup. It appears that none of my configurations take effect. The command ...
pgarcia-dev's user avatar
0 votes
1 answer
39 views

turtlebot3 manipulation is not loading in gazebo

I am trying to launch the turtlebot3 wth the open maniputor in gazebo here But when I follow the instructions, I get the output below. The arm is white and I cannot send any commands to the robot or ...
user1376339's user avatar
0 votes
1 answer
353 views

How to run ROS 2 on Kobuki Turtlebot 2

I have a Turtlebot 2 (with Kobuki base) that hasn't been used in a while. I will like to work with it using ROS 2. My first goal is the get it to the point where I can run simple applications on it ...
TrunkWhorl's user avatar
0 votes
1 answer
15 views

[solved] Creation of publisher failed: nav_msgs - turtlebot3

Hi everyone- I keep getting "Creation of publisher failed: nav_msgs" on my turtlebot3 after firmware and software upgrade per these instructions: https://discourse.ros.org/t/announcing-...
user avatar
0 votes
1 answer
5 views

ERROR: cannot launch node of type [create_node/turtlebot_node.py]: can't locate node [turtlebot_node.py] in package [create_node]

Hi, I am have installed turtlebot binaries. While executing : roslaunch turtlebot_bringup minimal.launch I am getting error as : ...
user avatar
0 votes
1 answer
1 view

Custom ROS capabilities. InterfaceNameNotFoundException

Hello! I am trying to implement a system of custom ROS capabilities for my lab-specific turtlebot_bringup. I've got it to the point where the capability_server recognizes that the package has ...
user avatar
0 votes
1 answer
1 view

Package "ompl" does not follow the version conventions

When I ran roslaunch turtlebot_bringup minimal.launch there have ...
user avatar
0 votes
1 answer
3 views

Where can I find the package turtlebot_bringup?

I am following this tutorial, directly after set up through this tutorial. I am using ROS indigo. When attempting to run the command ...
user avatar
0 votes
1 answer
5 views

Where is the Joint State information in a Create Turtlebot supposed to come from?

I am hacking at the Create based TurtleBot code to operate my own robot using ROS Hydro. I have created my own URDF modifications and some code changes. If I run: ...
user avatar
0 votes
1 answer
1 view

Kinect sensor not working?

Hi, I want to see the output of the 3DSensors of the turtlebot in simulation in gazebo. I am launching turtlebot in gazebo using command: roslaunch turtlebot_gazebo turtlebot_empty_world.launch then, ...
user avatar
0 votes
1 answer
3 views

rosluanch turtlebot_bring minimal.launch

I have some errors when I "rosluanch turtlebot_bring minimal.launch" Following message is the error message:: ...
user avatar
0 votes
1 answer
3 views

TurtleBot bringup error - "Robot not connected"

I'm trying to run the Bringup Tutorial for Turtlebot Groovy. But I always get ...
user avatar
0 votes
1 answer
5 views

Turtlebot bringup problems

Hello, I am having problems with the turtlebot_bringup package on Turtlebo 1 (iRobot Create base). I am using ROS Groovy on both the netbook and workstation, and I have edited the minimal.launch file ...
user avatar
0 votes
1 answer
1 view

Turtlebot Installtion help

Whenever I try to use the code roslaunch turtlebot_bringup minimal launch I get an error that says that it cannot locate minimal in package turtlebot_bringup what do I do? Originally posted by ...
user avatar
0 votes
1 answer
2 views

turtlebot_bringup error - invalid <param> tag

I installed turtlebot packages from debs. When I run minimal.launch I get the following error ...
user avatar
0 votes
1 answer
7 views

Turtlebot 2 errors

Updated: I removed everything from the turtlebot laptop and installed Ubuntu 12.04, installed ros-groovy-desktop and went through debs installation for the TurtleBot. I do not get errors with bringup ...
user avatar
0 votes
1 answer
56 views

Failed to open port /dev/ttyUSB0

Failed to open port /dev/ttyUSB0. Please make sure the Create cable is plugged into the computer. this is the message I get when I try to run ...
user avatar
0 votes
3 answers
4 views

Turtlebot Bringup

So I am going back through the steps of the bringup, since the demos are not working, and I try ...
user avatar
0 votes
1 answer
2 views

Bad Gyro Callibration

I am receiving the following error while running the Turtlebot dashboard: Level: Error Message: Bad Gyro Calibration Offset: The gyro average is outside the standard deviation. Gyro Enabled: True Raw ...
user avatar
0 votes
1 answer
1 view

ROS Answers SE migration: USB 3.0 Kinect

hello everyone ! I have a question.. I want to do this tutorial "http://www.ros.org/wiki/turtlebot/Tutorials/Looking%20at%20Camera%20Data" but.. when i enter this command "roslaunch ...
user avatar
0 votes
2 answers
3 views

Start Turtlebot

Hello I'm Korean Student. So I cannot speak English very well. Please excuse me.. I want to setup turtlebot.. so i did do this page step by step. http://ros.org/wiki/Robots/TurtleBot/Robot%20Setup ...
user avatar
0 votes
1 answer
1 view

Turtlebot bringup minimal.launch, cannot find create on dev/ttyUSB0

Every day I start up my turtlebot, I have the same problem with minimal.launch. Every day, I have to fix it, seemingly through random chance. I get it working, but it takes a significant amount of ...
user avatar
0 votes
1 answer
2 views

Turtlebot electric service does not start properly

I am running electric on my turtlebot, and when the turtlebot laptop boots up, the turtlebot service starts, but the dashboard remains grey, with no input from the turtlebot. The only way I can get ...
user avatar
0 votes
3 answers
9 views

Turtlebot Restarting Continuously

I have a turtlebot that was working properly in Diamondback, but when I upgraded it to electric (and upgraded the operating system on the workstation and netbook to Ubuntu 11.10), I am having several ...
user avatar
0 votes
1 answer
1 view

turtlebot_bringup failed to connect to iCreate

Recently, I have connected ArbotiX to my turtlebot, and I'm not sure at what moment, but iCreate is no longer recognized by ubuntu. ...
user avatar
0 votes
1 answer
9 views

Timestamps of Odometry and IMU

[ERROR] [1323209887.229712458]: Timestamps of odometry and imu are 1.490433 seconds apart. Can anyone explain the above error message? Is there a suggested fix? Thanks in advance. Originally posted ...
user avatar
0 votes
1 answer
4 views

Cant get data from Create robot - Error reading from SCI port ttyUSB0

Hi all, in the turtlebot-dashboard all the sensors are Stale apart from the Laptop battery one, and when I do roslaunch turtlebot_bringup minimal.launch I get the ...
user avatar
0 votes
1 answer
2 views

File structure question about ROS

I am installing a turtlebot arm onto my turtlebot and one of the instructions in the tutorial is : Setting up the URDF Next, we have to set up the TurtleBot's hardware description file (URDF) to ...
user avatar
0 votes
4 answers
4 views

No /dev/ttyUSB0 with iRobot serial->usb cable

Hi, Just trying to get started with the turtlebot bringup on an ASUS 1215N-PU27. I am using an iRobot serial to usb converter cable to connect the Create, but I am not seeing any corresponding USB ...
user avatar
0 votes
2 answers
2 views

Can't access turtlebot through ttyUSB0

Hi, I think that ROS can't access my Create... Is not possible see informations about the robot in turtlebot_dashboard, like battery and sensors status, but is possible to see netbook battery status, ...
Lucas Coelho's user avatar
0 votes
1 answer
1 view

kinect.launch for TurtleBot Not Working

When I type "roslaunch turtlebot_bringup kinect.launch" in order to start my kinect for map building, I get these messages published over and over again. What do you think is the problem? <...
user avatar
0 votes
1 answer
4 views

Turtlebot Bringup error

Hi everyone, The kubuntu was already installed on laptop, so I installed ros-electric-turtlebot, ros-electric-ros and ros-electric-apps and I configured the networks settings. But when i type "...
Lucas Coelho's user avatar
0 votes
1 answer
7 views

TurtleBot BringUp Errors

Hi everyone, (Warning: I'm new to TurtleBot, ROS, and UBUNTU) I'm having trouble bringing up my TurtleBot. I installed Ubuntu 11.04 Natty and ROS on my Laptop/TurtleBot and my Workstation. I setup the ...
user avatar