Skip to main content
Share Your Experience: Take the 2024 Developer Survey

Questions tagged [rtabmap-ros]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
0 answers
17 views

nav2 is dropping lidar messages

I'm trying to use rtabmap with my robot and I use both odometry from wheels and visual odometry. It works, but my 2D lidar (which is not used in rtabmap, but used in nav2) cannot be transformed ...
ArtemKondratev's user avatar
0 votes
1 answer
44 views

Low quality map with RTAB-Map

I'm trying to create a map via differential drive robot with RGBD camera Intel RealSense D435i and wheel odometry using RTAB-Map. The map is low quality (right picture). Also, I have a map which ...
ArtemKondratev's user avatar
0 votes
0 answers
13 views

rtabmap source panel disabled

I am working on multi-session mapping with rtabmap. I am following this tutorial. but my source is disabled and even I can't find "File->Open database..." option in my gui. I am using ...
sai's user avatar
  • 1
0 votes
0 answers
26 views

rtabmap 0.21.3 - Rtabmap: Parameter "GridGlobal/FullUpdate" doesn't exist anymore!

recently I updated my system with "sudo apt update" and "sudo apt upgrade" and rtabmap passed to 0.21.3 version but now I am having trouble launching rtabmap ( "rosrun ...
Jacopo Tedeschi's user avatar
0 votes
1 answer
37 views

RTAB-MAP Android version , adding ros inputs/outputs

I want to know if someone have done any work on RTAB-MAP Android, I'm trying to add ROS input/output to the Android version but maybe its a too big challenge for me so I try to find someone to help. I ...
Blueetooff's user avatar
0 votes
1 answer
60 views

Negative baseline in RTABMAP with OAK camera

I have an OAK-D Pro W PoE camera and I am trying to follow this tutorial to perform SLAM with RTABMAP in ROS noetic. I follow all steps but I receive the following error message when I launch rtabmap....
Alessio Aristodemo's user avatar
0 votes
0 answers
113 views

How to launch rtabmap_ros?

I have been following the Nav2 tutorial when I reached the robot_localization part and decided to launch rtabmap using a Kinect rgbd camera for map generation I found this schema which I need to ...
quark epsi's user avatar
0 votes
0 answers
92 views

Rtabmap tf issue with ekf

I am trying to use Rtabmap with filtered odometry from ekf (robot_localization) I used the turtlebot demo, but changed the topics for my robot. It works, the map looks alright, but there is a constant ...
ALNA_Perera's user avatar
0 votes
1 answer
18 views

Is there a flag or member variable that I can access to indicated odometry lost in RTAB-Map?

Is there a flag/service/variable that I can access programmatically which will indicate rtabmap odometry lost? I am attempting to use rgbd_odometry (RTAB-Map 0.21) in ROS-Noetic, and requires stopping ...
Hafiz Iman's user avatar
0 votes
1 answer
48 views

Rtabmap has a few jumps in odometry

I'm using the LEO rover gazebo simulator, to simulate the robot on Marsian terain. I'm running rtabmap, to map the world around the rover. The problem I'm running into, is that rtabmap sometimes finds ...
Krzo's user avatar
  • 11
0 votes
1 answer
143 views

Transform the map frame into custom global coordinate system

I'm running RTABMap and mapping is working correctly with Lidar, odometry and RGBD sensor data. In order to overlay the generated map with a CAD model, I need to transform the map frame into the CAD ...
user avatar
0 votes
1 answer
202 views

3D Navigation (navigation in uneven terrain)

I am trying to develop a project in which I have to navigate a robot through a cave. The problem is that the cave's terrain is very uneven and so creating a 2D costmap to use Nav2 afterwards isn't an ...
user avatar
0 votes
1 answer
5 views

Error while running rtabmap for the real robot!

Hi, I connected to the real vehicle and launched rtabamp, but it shows the following error: ...
user avatar
0 votes
1 answer
2 views

how are you suppose to use the param tag

im using rtabmap and i think im using the params wrong. where do i need to place them do they need to go inside the node tag like: ...
user avatar
0 votes
1 answer
68 views

rtabmap: Did not receive data since 5 seconds ! (but it should be receiving !)

Hello, I'm using ros-noetic-desktop-full/focal,now 1.5.0-1focal.20200826.205403 amd64 [installed] on Ubuntu 20 rtabmap says it's not receiving data but the topics ...
user avatar
0 votes
1 answer
5 views

Camera view occluded by robot body, how to deal for SLAM?

On my mobile robot, I have a RGBD camera(zed) which even at the lowest resolution/fov setting, captures part of the robot body. When performing visual SLAM using RTabMap unfortunately the body is ...
user avatar
0 votes
1 answer
7 views

rtabmap_ros tutorial zed_stereo_throttle.launch gives unused args error

At the moment I'm trying to use remote mapping on a robot with a jetson tx2 and a laptop with ubuntu 16.04. Both run with ros kinetic. Following this tutorial http://wiki.ros.org/rtabmap_ros/Tutorials/...
user avatar
0 votes
2 answers
33 views

Error while using rtabmap with remote D435i input: TF_OLD_DATA

Hi, I'm fairly new to ROS and apologize in advance if my question is stupid. What I'm trying to do is to have a rover carrying a Pi and camera remote mapping its environment while the main computing ...
user avatar
0 votes
2 answers
24 views

Why can't rtabmap_ros access the published zed camera topics?

Hi, I'm new to ROS and currently working on using rtabmap with move_base and the zed camera on a jetston-tx2 for Navigation. I start the roscore on the Host machine. Than I start the zed node on the ...
user avatar
0 votes
1 answer
12 views

rtab-map to scan the PLAIN wall in front of the robot

Hello, i'm working on a robotic arm which can be equipped with a realsense or a zed rgbd camera. The camera is attached to the end-effector of the robot, so im able to make a "zig-zag" (from ...
user avatar
0 votes
1 answer
13 views

'make' fails when building the rtabmap package

Hi, I was using rtabmap_ros version 0.17.6 and working on SLAM with Gazebo as shown here. I wanted to take a look at the map that is stored in ~/.ros/rtabmap.db and ...
user avatar
0 votes
1 answer
29 views

How to Navigate the Robot using RTABmapViz

Hi, I am using rtabmap_ros package to simulate 3D mapping and navigation of the mobile Robot. As for the first part, I can generate the 3D map of the environment simulated in gazebo. However, when I ...
user avatar
0 votes
1 answer
2 views

Custom Data Input to RTAB instead of Kinect data

I have a python script which after processing, gives me Depth Map and RGB Input image in realtime. I can not connect kinect directly, but I want RTAB Map to create a map based on the live stream of ...
user avatar
0 votes
1 answer
12 views

Unable to move turtlebot or create map when using custom world in Gazebo

Hi, I am new to using ROS (and Ubuntu) and am reaching out as I've hit a snag. I am trying to use the rtabmap_ros tutorial for mapping and navigation using turtlebot (the simulation portion) and am ...
user avatar
0 votes
1 answer
16 views

Unable to build RTAB map using 2d rotating LiDAR

Hi, I'm using a rotating 2d lidar and then using laser assembler package to get 3d point cloud. Video I can see the point cloud but when I used in RTAB no map frame is generated neither it is able to ...
user avatar
0 votes
1 answer
23 views

Very low rate of obstacles_detection rtabmap

I am using the standalone nodelet obstacles_detection to get the obstacles from my stereo camera. When I run it, I get a slow rate of < 1 Hz and for the real-time obstacle detection that is not ...
user avatar
0 votes
1 answer
13 views

Why does RTABmap subscribing to my other TF?

I have noticed some problem. When I launch RTABmap, it subscribes to my noisy_odom TF and also subscribes to filtered_odom TF and I think it makes my map being messy and sometimes I get this warning: <...
user avatar
0 votes
1 answer
24 views

How to launch nodelet? (RTABmap)

Hi, I came up across remote mapping and RTABmap provides this launch file: ...
user avatar
0 votes
1 answer
4 views

All spaces are occupied using RTABmap stereo

Hi, I am trying to map the area using the stereo camera and after looking at produced map, all the cells are black, meaning occupied. I have tried to figure out for 2 days but still struggling to ...
user avatar
0 votes
1 answer
6 views

Why does pointcloud pointing upwards?

I am using a camera remotely and sending the compressed image frames to host pc. I am using RTABmap to create a 2d MAP. The problem occurs when the PCL is being published and the points are located ...
user avatar
0 votes
1 answer
19 views

Use RTAB-Map with ORB_SLAM2 in ROS

Hello everyone, I successfully compiled RTAB-Map with Orb-Slam2, so I can now choose ORB-SLAM2 as an odometry strategy in RTAB-Map standalone app. Now I would like to use it inside ROS. I guess that ...
user avatar
0 votes
1 answer
16 views

Trouble localising with RTAB-Map

I have recorded a map using an Intel Realsense camera(D435i) and RTAB-maps. This is the command I am using to record the map ...
user avatar
0 votes
1 answer
7 views

rtabmap_ros in simulation

Is there a way to launch the database file and publish it to ROS when running in simulation, i.e. when the sensors are not connected? I would just use it for visualization and for generating the ...
achille's user avatar
  • 361
0 votes
1 answer
13 views

rtabmap using stereo camera that exports rectified and disparity images

Hi, I am using stereo camera that is calibrated and exports rectified and disparity images. The tutorial in here gives two examples of a stereo camera that exports raw images. In the first stereo use-...
user avatar
0 votes
1 answer
6 views

Rtabmap_ros does not show octo map but points clouds are good

Hi Im using two point Grey Chameleon3 mono camera set up as Master Salve and synchronized so can work as stereo camera. I have a installed ROS driver and able to publish the camera topics . Im using ...
user avatar
0 votes
1 answer
26 views

rtabmap_ros with Stereo Camera launch file and build a map, not working?

Hi Im using two point Grey Chameleon3 mono camera set up as Master Salve and synchronized so can work as stereo camera. I have a installed ROS driver and able to publish the camera topics . Im using ...
user avatar
0 votes
1 answer
6 views

RGB-D Handheld Mapping with RealSense R200

I was following the RGB-D Handheld Mapping tutorial . First I ran the following command $ roslaunch realsense_camera r200_nodelet_default.launch While the ...
user avatar
0 votes
1 answer
42 views

RTABMAP 3D map errors

Hi, I'm trying to build a 3D map remotely with RTABMap over WiFi. I'm running a navigation stack, Rosaria, freenect and depthimage_to_laserscan nodes on Raspberry Pi 3 which is interfaced with Kinect ...
user avatar
0 votes
1 answer
2 views

ROS Answers SE migration: rtabmap+3d map

hi all, i used rtabmap to created 3d map from environment. i used stereo camera for this. my question is that, in rtabmap, How is the 3D map created for stereo camera? it is feature based or area ...
user avatar
0 votes
1 answer
15 views

How to export key frames and camera poses using RTABMAP automatically

Hi, I am using RTABMAP for 3D mapping. But I need to write shell script to run the SLAM and export key frame images and poses. Is there any method to export them without using mouse click operation at ...
user avatar
0 votes
1 answer
22 views

demo_turtlebot_mapping.launch+rtabmap

hi, i want create map with turtlebot in Gazebo with rtabmap. i used this link link text and step 6. but when run turtlebot in gazebo map is not create and this message is created in terminal: ...
user avatar
0 votes
1 answer
15 views

turtulbot+rtabmap

hi i have stereo images that save in a directory. i used rtabmap_ros package and this launch file for created map and localization: ...
user avatar
0 votes
1 answer
6 views

rtabmap error:[ERROR]: Skipping XML Document ".../nodelet_plugins.xml" which had no Root Element. This likely means the XML is malformed or missing

hi when i run rtabmap this error is occure and in localization mood map is not load: [ERROR] [1517006470.211027541]: Skipping XML Document "/opt/ros/indigo/share/gmapping/nodelet_plugins.xml"...
user avatar
0 votes
1 answer
11 views

navigation with known map+rtabmap

hi i created map with rtabmap and saved. but for navigation the saved map not open. I used rtabmap_ros on a Turtlebot in Gazebo and this is my launch file: ...
user avatar
0 votes
1 answer
23 views

rgbd_odometry: Did not receive data since 5 seconds (zed camera)

after i install rtabmap from source when i try to run it i got this error: [ WARN] [1516726659.614500547]: /rtabmap/rtabmap: Did not receive data since 5 seconds! Make sure the input topics are ...
user avatar
0 votes
1 answer
12 views

rtabmap with stereo images

hi, i used this file link text for create map and localization by stereo images. but when i used parameter (rviz:=true), rtabmapviz and rviz simultaneous run and this error is created: [pcl::...
user avatar
0 votes
1 answer
6 views

rtabmap+Turtlebot+stereo images

hi, i am new in rtabmap and have a question . can i use the demo_turtlebot_mapping.launch for turtlebot in simulation (Gazebo) by use of stereo images? Edit: hi matlabbe i change launch file ...
user avatar
0 votes
1 answer
51 views

RTAB-Map not using correct parameters

I've been trying to get RTAB-Map going in simulation using a depth camera plugin. I've been able to get it all working, however it seems that RTAB-Map uses its default parameters, rather than the ones ...
user avatar
0 votes
1 answer
12 views

rtabmap+pose file

hi, i am following the tutorials of rtabmap and use this package for stereo vision. i created the map with stereo images from file (link:https://github.com/introlab/rtabmap/wiki/Stereo-mapping) for ...
user avatar
0 votes
1 answer
6 views

rtabmap+Turtlebot+stereovision

hi all, i am new in ros and rtabmap. my goal is create map and navigate around the map with simulator robot. my work is not on line. i captured stereo images from two web cam and save these images at ...
user avatar