Questions tagged [openni-camera]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
1 answer
1 view

how to make openni_camera package to output 320x240 rgb and depth images directly

hi, in openni_camera, i got to know that it's ROS API has parameters like: ~image_mode (int, default: 2) Image output mode for the color/grayscale image Possible values are: SXGA_15Hz (1): 1280x1024@...
user avatar
0 votes
1 answer
3 views

How to install openni_camera & openni_launch package in ROS groovy on Raspberry Pi

Hello I am using ROS groovy in Raspberry Pi2 with bare bones installation. i want to obtain the rgb and depth stream from kinect using rosrun commands like rosrun openni_camera openni _node & ...
user avatar
0 votes
1 answer
1 view

Select published topics

Hello, I'm using the openni_camera and openni_launch stacks with ROS fuerte on a platform with low processing power. I only need two topics: /rgb/image_rect and /depth_registered/image_rect. Is there ...
user avatar
0 votes
1 answer
1 view

openni_camera/openni_launch fuerte repository access denial

Hi, I cannot clone the ros openni_camera mercurial repository , authentication failure. Even after I registered at : kforge.ros.org/openni/openni_camera After I login via web, it shows: Access Denied ...
user avatar
0 votes
1 answer
1 view

PR2 cannot reset after installing openni_camera

Hi I wanted to use the kinect on PR2 so I installed the openni_camera using sudo apt-get install ros-fuerte-openni-camera. After doing that,I could not reset the robot anymore. The reset option on ...
user avatar
0 votes
1 answer
1 view

openni_launch - ROS Fuerte

Hi all! Since ROS Fuerte openni_camera and openni_launch are two different packages. When I like to use the Camera topic in rviz, which node do I have to start? Thanks for your help! Originally ...
user avatar
0 votes
1 answer
9 views

How to parse sensor_msgs::Image data?

Hi, This may be trivial, but I have problems understanding how to parse data which comes as sensor_msgs::Image. I used the package openni_camera to get raw frames (camera/depth/image_raw). It says ...
user avatar
0 votes
1 answer
1 view

Rosmake openni_camera on fuerte fails

I'm trying to make the openni_camera-fuerte-devel package, but it fails. Here is the output: ...
user avatar
0 votes
1 answer
3 views

Undefined reference to log4cxx when adding openni_camera dependency to package

Hi, I've been struggling with this for a few hours. I created a package depending on openni, openni_camera and ...
user avatar
0 votes
1 answer
1 view

Invalid point cloud from Kinect by using openni_camera

I recently upgraded my Ubuntu from Natty to Oneiric. Since we were developing a project under ros-electric, I thus upgraded the original ros-electric for Natty to ros-electric for Oneiric too. ...
user avatar
0 votes
2 answers
1 view

Error with openni.launch groovy in Raspbian

Hi! I'm trying to use Openni to use the Kinect in my Raspberry Pi, but I can't make it run. I'm using the image from the installation tutorial, and installed the openni_launch package in my workspace ...
user avatar
0 votes
1 answer
1 view

roslaunch openni_camera openni_node.launch on multiple client

Hi, Greetings. I am using ROS Electric. I have three ROS station, one is master and other two are client machines. Each client machine has its own Kinect. Master's IP is configured as ROS_MASTER_URI ...
user avatar
0 votes
1 answer
3 views

How to link OpenNI and NITE as external libraries

I'd like to link OpenNI and NITE to my own package as external libraries. How can I do it? I'm using ROS groovy with Ubuntu 12.04. In order to rosmake my package which uses OpenNI and NITE, I ...
user avatar
0 votes
1 answer
4 views

Kinect not recognized by OpenNI drivers

Our lab recently got a PrimeSense Carmine sensor, which isn't supported by ROS Fuerte's OpenNI drivers. We followed the suggestions of a previous ROS answers post, which added support for the Carmine ...
calderpg's user avatar
0 votes
1 answer
1 view

unmet dependencies while rosdep install openni_launch

Hi , I am just trying to install openni_launch and openni_camera to get my asus xtion pro live to work. I have ubuntu 12.04 and fuerte. when I type rosdep install openni_camera sai@sai-HP-EliteBook-...
user avatar
0 votes
1 answer
1 view

Disabling unused streams for openni_launch

I am using openni_launch to start my kinect. Per default it publishes a lot of topics (IR, Depth, RGB in mono, rectified, registered, compressed, theora versions). I would be interested if it is ...
user avatar
0 votes
1 answer
1 view

openni_camera compilation error

Hi, I'm trying to compile openni_camera with rosmake, but an error occured : XnCppWrapper.h : No such file or directory I don't know what to do... Thank you ! Originally posted by AnSooooo on ROS ...
user avatar
0 votes
2 answers
2 views

rosmake openni_camera gives an error

Hi, i had to reinstall my system. Before, i made a backup of my ros workspace. After installing ros, i tried my old launch files and they don't work. I solved some errors already. But, if i try to ...
user avatar
0 votes
1 answer
3 views

Calling xn_sensor_server_cleanup.sh from launchfile

There are a lot of threads on a bug in openni that crash the kinect because xnsensorserver is not shut down correctly. The solution seems to be to run this script (xn_sensor_server_cleanup.sh) from ...
user avatar
0 votes
2 answers
3 views

Calling nodelet manager service from console

Hey. My question concerns how to use the nodelet manager service properly. Consider a nodelet manager has been started and is running. It's rosservice to load a nodelet (/manager/load_nodelet) is also ...
user avatar
0 votes
1 answer
1 view

pi-robot pkg for kinect - process has died error

Hi, After installing openni_camera and pi-robot package (skeleton_markers and pi_tracker), I've been trying to run the skeleton tracking launch files, but always fails with the message like this: [...
user avatar
0 votes
1 answer
1 view

No registered depth image in Fuerte

I am using the /camera/depth_registered/image_rect message from a kinect using openni_launch, but he message is not sent in Fuerte. I tried setting depth_registration: ...
user avatar
0 votes
1 answer
1 view

openni_camera operation mode 7

Dear community, I am fooling around with the operation mode parameters for rgb and depth images on the openni_camera driver When I set image_mode and depth_mode to 8 (160x120 @ 30FPS) everything works ...
user avatar
0 votes
1 answer
6 views

unable to get point cloud from /camera/depth/points in rviz

I did : rostopic echo /camera/depth/points it seems topic is publishing messages. However, when i launch rviz- setting fixed frame to /camera_link or /...
user avatar
0 votes
1 answer
2 views

openni_camera crash while using kinect

I recently updated all my machines, and cannot seem to run the openni driver with the kinect anymore (tested across 2 different fuerte/precise machines and 2 different kinects). openni_camera is ...
user avatar
0 votes
1 answer
2 views

Kinect explore.launch failed again in Husky A200

Hi, I had previously made explore and human tracking work well with Husky A200. However, recently when I tried to do the same again today it did not work. I tried several things to repair this but ...
user avatar
0 votes
1 answer
1 view

Kinect laser problems

...
user avatar
0 votes
1 answer
2 views

why is tf frame changing?

Hallo, I am using a Kinect mounted on a PR2, ROS Electric and the openni_camera package from the openni_kinect stack. After starting the Kinect driver with rgb_frame id: /openni_rgb_optical_frame and ...
user avatar
0 votes
1 answer
1 view

Asus Pro instead of Asus Pro Live

Hi, i am using the openni_camera module together with the openni_launch on ubuntu 12.04 and fuerte. when i run openni_launch, it detects the device, but sadly not correct. It detects my Xtion pro live ...
user avatar
0 votes
1 answer
1 view

Accurate distance to kinect with Openni

Hi, I know this question might be very easy but I could not find a direct solution for that in the previous questions. I have a kinect and I use openni_tracker to detect the person's joint. Now I want ...
user avatar
0 votes
1 answer
9 views

RVIZ not showing PointCloud2

Hi, I have an issue using RVIZ when I try to visualize my data coming from Kinect using the following: $ roslaunch openni_camera openni_node.launch $ rosrun rviz rviz C:\fakepath\Screenshot-13.png ...
user avatar
0 votes
4 answers
2 views

openni_launch not working in fuerte + ubuntu precise 12.04

EDIT 4: I tried launching the driver on a fresh install of fuerte on a fresh install of precise, following all ros install instructions to the letter. Still get the same error. And I tried this on ...
user avatar
0 votes
2 answers
1 view

Openni launch process has died

When running : roslaunch openni_camera openni_node.launch I face the following problem: [ INFO] [1335797962.331964828]: [/openni_node1] Number devices connected: 1 ...
user avatar
0 votes
1 answer
3 views

cv::bilateralFilter segfaults on image from cv_bridge

I have a ROS node that takes in a depth image and converts it to an openCV compatible format. However it doesn't seem to be compatible with all openCV functions. ...
user avatar
0 votes
1 answer
1 view

What's the differences between the packages openni_camera and openni_launch?

There are 2 launch files kinect_frames.launch and openni_node.launch and 1 node openni_node ...
user avatar
0 votes
2 answers
1 view

Cannot record sensor data using rosbag from kinect

Hi, I tried to record the data from Kinect by using rosbag record -a after I opened the openni_node driver for Kinect. ...
user avatar
0 votes
1 answer
1 view

Using the OpenNI Kinect and the Nyko Zoom attatchment

I'm working on person tracking with the Microsoft Kinect and the Nyko Zoom attachment. I need accurate distance estimates to/between each person and, of course, the Zoom warps the Kinect image. Thus,...
user avatar
0 votes
1 answer
2 views

Asus Xtion Pro Live poor framerate

I am excitedly trying out our newly arrived Xtion Pro Live cameras. Unfortunately, I see behavior that on the same laptop, Kinect runs at 30FPS (as determined by rostopic hz), while through the same ...
user avatar
0 votes
1 answer
1 view

device_id is not set on kinect.launch for turtlebot

Turtlebot dashboard is showing no errors, the first four squares are green as they should be, and it is in full mode. I started it up using ...
user avatar
0 votes
1 answer
1 view

Kinect - no devices connected on openni_node.launch

Hi all, I'm starting with the turtlebot but can't get the Kinect to be recognized. I am runnig diamondback. I redid sudo apt-get install openni_kinect just to make ...
user avatar
0 votes
1 answer
2 views

Kinect problem - [/openni_camera] No devices connected

Hi, there, I'm trying to connect Kinect with turtlebot, but it is not working. First of all, I was following instructions on how to "hack" kinect cable and connect it with power board which ...
user avatar
0 votes
1 answer
1 view

openni and ar bounding box doesn't work well together

Hi everyone, I'm working with the RoboEarth package to model 3D Objects. The results were mediocre and because of that we tried to calibrate our kinect. (using this tutorial: http://www.ros.org/wiki/...
user avatar
0 votes
1 answer
1 view

Kinect can't be connected to my netbook

I'm using Ubuntu10.10. Following the diamondback installation instruction, I installed the ros-diamondback-turtlebot-robot,and finished turtlebot setup,networking setup,environment setup. There was ...
user avatar
0 votes
1 answer
1 view

no data from the kinect

HI everyone.Im using openni kinect to get the data image from the Kinect,I followed the steps online ,on ros.org but i dont get any data from the kinect. thanks in advance for your help! Originally ...
user avatar
0 votes
1 answer
5 views

Problems of NaN positions when converting PointCloud2 to pcl::PointCloud PointXYZRGB

Hello I have tried to convert PointCloud2 message from openni_kinect to pcl::PointCloudpcl::PointXYZRGB. And I have some critical problem when I check position information of PointXYZRGB. All position ...
user avatar
0 votes
2 answers
2 views

Calibrating in OpenNI_Kinect

Hi all, I was wondering if it was possible to calibrate the Kinect in the openni_camera package, and if there was a standard way to do this. I did stumble across the following link: http://www.ros....
user avatar
0 votes
1 answer
1 view

openni detecting device only in debug mode

Hi all, I'm trying to run the openni_node.launch file on a PR2 with ubuntu lucid and diamondback. When starting the launch file with "debug=true" the kinect is detected correctly and I can ...
user avatar
0 votes
1 answer
4 views

Get RGB pixel coordinate in depth cloud

Hi there! I'm using pcl point cloud to show depth information obtained with kinect. I'd like to identify rbg points (pixels) on the depth map (for example eye balls). How can i obtain real world ...
user avatar
0 votes
4 answers
1 view

Kinect not detected

Hi, I previously posted an issue regarding errors in openni drivers installation (http://answers.ros.org/question/2297/openni-drivers-installation-errors). With the answer to this question i was able ...
user avatar
0 votes
2 answers
1 view

openni_kinect dosen't publish anything in the topics or rviz

Hi, I'm very new to ROS so bare with me a bit, I've just installed Electric on Ubuntu 11.04 on an Toshiba L650 laptop (ATI VGA) I've installed opennni_kinect using the package As I understand all I ...
user avatar