Questions tagged [libfreenect]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
0 answers
81 views

Trouble connecting Kinect V1 with ROS Noetic

I am currently attempting to connect the Kinect V1 RGB-D camera with ROS Noetic. So far I have used the following approaches according to the instructions given in the link [https://aibegins.net/2020/...
sai mouli manohar rao's user avatar
0 votes
1 answer
12 views

Get only depth data from Kinect using libfreenect

Hi, In order to reduce the amount of CPU freenect nodelet is using on my robot I would like to get only the topic "camera/depth_registered/image_raw" cause this is the only one I need right ...
user avatar
0 votes
1 answer
2 views

Libfreenect driver on ros

Can anyone tell me how to use libfreenect driver on ros with a python script? I am using kinect Originally posted by tsw on ROS Answers with karma: 11 on 2017-10-30 Post score: 1
user avatar
0 votes
2 answers
16 views

What is the difference between iai_kinect2 and libfreenect2?

Hi, I bought Kinect V2 (MISTAKE) and have to use it for gmapping because my university won't grant me more funds. I have already installed libfreenect2. Do I also need to install iai_kinect2 . In case ...
user avatar
0 votes
1 answer
7 views

Rtabmap transform error with kinect

So I want to use rtabmap in order to map my environment. I am using Freenect to extract the data from the kinect using ...
user avatar
0 votes
2 answers
7 views

Kinect v2 "No devices connected..." I've tried everything

I'm at the point, I've tried literally everything for weeks now to get any kind of visualization and no dice because of No devices connected error. I'm on an intel i7 w/ hd graphics 4k running ubuntu ...
user avatar
0 votes
1 answer
4 views

Ubuntu 12.04 on PR2 is unable to install libfreenect-dev

Hello, I am working on a PR2 robot (hydro) and I would like to install libfreenect-dev to develop a package for rgbd (kinect) mapping. However, I cannot install this library. I receive the message &...
user avatar
0 votes
1 answer
9 views

Installing freenect_stack from source

I downloaded the source code for freenect_stack from git to the src folder of my catkin workspace. When I tried to build it using catkin_make, I got the following error: ...
user avatar
0 votes
1 answer
1 view

How do I release a 3rd-party library to Hydro with the same patches as Groovy

I had to apply very many patches to get libfreenect working on Groovy. I want to release exactly the same patched code to Hydro. The bloom 3rd-party release ...
user avatar
0 votes
1 answer
2 views

Libfreenect not finding the Kinect

This is sort of a follow up to this about libfreenect. I successfully got ROS installed on RaspberryPi (ARM) and compiled freenect_stack from @piyushk. I complete all of the steps, but it can't find ...
user avatar
0 votes
1 answer
3 views

Error compiling libfreenect stack

Hello all, I am currently trying to rosmake the freenect_stack Piyush is maintaining. I downloaded the drivers on the desktop in the lab and they compiled fine. However, when I tried to compile on the ...
user avatar
0 votes
2 answers
4 views

Libfreenect drivers for ROS

Hello all, I am trying to use the old libfreenect drivers on the ROS.org website. But I can't seem to be able to install them using apt-get install ros-fuerte-kinect. Does anyone know how I can get ...
user avatar
0 votes
2 answers
1 view

Do kinect topics depend on drivers

I happened to have downloaded a bag file of Kinect which was recorded with the help of libfreenect driver. If i develop a node which is for kinect and that uses Openni driver. Will there be ...
user avatar
0 votes
1 answer
1 view

K4W with openni

I've been looking into using Kinect for Windows on Ubuntu. However, it seems not to be possible with openni at the moment. I found an interesting post regarding libfreenect, where they apparently did ...
user avatar
0 votes
1 answer
1 view

Installing the deprecated kinect stack

I'm trying to install the old kinect stack that was based on libfreenect because I need it for a SLAM solution that I want to install. Apparently, the stack source that I downloaded does not come with ...
user avatar