Skip to main content

Questions tagged [libboost]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
0 answers
25 views

Gazebo Server error: Assertion `px != 0' failed. Libboost

I am working on a ROS project but when I do the simulation in Gazebo I get this error. It is inconsistent, sometimes it does not happen, but when it triggers it happens after different times (eg. ...
CeliaRV's user avatar
0 votes
1 answer
2 views

CCNY RGB-D tools Installation Problem

Hi, I downloaded the tools from github and followed the instructions to install them. However the installation fails with the message ...
user avatar
0 votes
1 answer
4 views

Two versions of libboost?

I've seen that running two versions of libboost will cause problems, but I can't figure out how to upgrade my libboost so that I can use an external library. I'm using the vicon_bridge package, which ...
user avatar
0 votes
1 answer
1 view

Install ROS Groovy alongside Boost 1.55

Hi, I'm trying to install ROS Groovy (but the error also exists with Hydro), but it won't install unless I uninstall my new version of Boost. However, I also want to use the newer Boost library, since ...
user avatar
0 votes
1 answer
1 view

Problem running ApproximateTime Policy tutorial

I'm trying to make use of the an ApproximateTime synchronization, however I am having a boost library related issue with that. Then I decided to test the actual ros tutorial here. Here is the source ...
user avatar
0 votes
2 answers
2 views

problem example ROS C++ no rule to make target libboost_signals

Hi, I have a fresh install of Ubuntu 13.10 server. I installed ROS hydro base, and follow the examples, but when I'm trying to make the Publiser/Suscriber example (C++) I have the following error make[...
user avatar
0 votes
1 answer
1 view

libboost error during linking

...
user avatar
0 votes
1 answer
1 view

Compiling ROS Fuerte with boost 1.46.1

Hello, I have a problem similar to this one. I am running Ubuntu 10.04 32-bit, kernel 2.6.32.59 and gcc version 4.4.3 (Ubuntu 4.4.3-4ubuntu5.1). I am trying to compile ROS Fuerte from source against ...
user avatar
0 votes
1 answer
1 view

Compiling ROS with boost >1.41

Hello everybody. I have Ubuntu 64 bits 10.04 with kernel 2.6.32-38-generic and gcc (Ubuntu 4.4.3-4ubuntu5.1) 4.4.3. The problem I have is that I need to compile ROS (Electric or Fuerte) with boost 1....
user avatar
0 votes
1 answer
1 view

Problem compiling face_recognition (procrob_functional)

Hi Ros users, I would like to use face_recognition (procrob_functional) but I have got an error while compiling : /usr/bin/ld: CMakeFiles/Fclient.dir/src/face_rec_client.o: undefined reference to ...
user avatar
0 votes
1 answer
2 views

Linking error libboost_system with tabletop_object_detector

Hey, I decided to upgrade my laptop to Oneiric today and after fixing quite a few new issues, I'm stuck on an issue I can't seem to get fixed. When rosmaking tabletop_object_detector I get the ...
user avatar
0 votes
1 answer
2 views

Unable to build face_detector for Electric

Hi, I'm trying to build face_detector from https://code.ros.org/svn/wg-ros-pkg/stacks/people/trunk/face_detector but it fails with the following error. ...
user avatar
0 votes
1 answer
1 view

Boost1.40-dev error in electric

I am trying to migrate a package working under diamondback to electric. When I switch to electric I get errors with boost header files. It appears that the implementation of ros/time.h in electric is ...
user avatar
0 votes
1 answer
1 view

libboost1.46-all-dev

I am doing an install on LMDE, which uses the latest debian repositories. rosinstall fails when it cannot install libboost1.42-all-dev. libboost1.46-all-dev is available in the repository. Is there ...
user avatar