Skip to main content

Questions tagged [amcl]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
1 vote
0 answers
7 views

ROS2 Navigation2 Configuration for Dynamic Environment

I am currently deploying an AMR for logistics use case in a Warehouse based on ROS2 Humble. It is a traditional warehouse where the environment is changing frequently (every 15 minutes). Almost all of ...
Michael Jonathan's user avatar
1 vote
0 answers
14 views

Local Costmap is not receiving map in "Odom global frame" while using AMCL and GMapping in SLAM

I am implementing SLAM using the AMCL (Adaptive Monte Carlo Localization) and GMapping packages in ROS. While the map is successfully displayed on the Global Costmap, it does not appear on the Local ...
Muhammad Wasiq Saleem's user avatar
0 votes
0 answers
12 views

NAV2 Custom Robot is not following path while moving

I prepared a custom robot and whenever I publish velocity from the teleop, it moves well. My robot hasn't got IMU but it is localizing and mapping via LIDAR. It generates a map successfully with ros2 ...
Eren's user avatar
  • 1
0 votes
1 answer
11 views

nav2 amcl robot local costmap offset from global costmap

I have a problem using nav2 and amcl on a gazebo-simulated robot in which the odom frame and local costmap drift as the robot moves. Please see the screenshot below. Here is the environment for ...
David Brown's user avatar
0 votes
0 answers
43 views

ROS AMCL Localization base_link to odom transformation extrapolation problem

I am trying to build a simple autonomously navigating robot using ROS Noetic on a Raspberry Pi 4 with ubuntu 20.04 and I am using RPLiDAR A1 as LiDAR.. I recorded a map and try to localize within that ...
Emir Alp Ayar's user avatar
0 votes
0 answers
11 views

Omni Robot with ros_planar_move 4 wheels doesnt behave like omni robot

everyone. I'm trying to enable navigation on a 4-wheel omni robot but it doesnt behave like expected, no y-linear velocity commands. I have tried all different controllers and planners to no effect. ...
Lourenco Conceicao's user avatar
0 votes
1 answer
40 views

AMCL is not publishing map -> odom TF [HUMBLE]

I'm working with an ackermann car-like robot. I've just created a map with SLAM and now following the turtlebot3 tutorial I'm loading it in the NAV2 launch with the AMCL. The thing is the map frame is ...
dani santana's user avatar
0 votes
1 answer
58 views

lidar laser scan points rotated in nav2

I am simulating a simple custom robot in Gazebo Fortress and controlling it with nav2 using AMCL for localization. Everything is working normally using odometry only, but I am now observing strange ...
David Brown's user avatar
1 vote
0 answers
21 views

planar_move_plugin and navigate to goal with unexpeceted behaviour

I'm developing a 4-wheel omni drive robot in a simulated environment, and I can teleoperate it with a joystick. However, when using nav2 for localization and autonomous navigation, it doesn't plan ...
Lourenco Conceicao's user avatar
1 vote
0 answers
21 views

AMCL not updating the map - odom tf when robot navigating

Hello Im trying to autonomously navigate a robot using ros. I have created a launch file to start the navigation stack for the robot Here is my launch file for the robot. ...
Dinoj's user avatar
  • 21
0 votes
0 answers
35 views

Lidar shows very few points. RPLIDAR A2M8

I'm using an RPLidar A2 for Slam on my robot but after mapping, when I am trying to localise, the lidar shows very few points. Is this normal? This lidar supposedly has a 12m range. Because it sees ...
Crab00189's user avatar
1 vote
0 answers
27 views

laser_frame is moving

When I launch AMCL and give initial pose , the amcl launched terminal shows: Failed to transform initial pose in time (Lookup would require extrapolation into the future. Requested time 1706706126....
Vinoth's user avatar
  • 11
0 votes
0 answers
38 views

Multi Robots AMCL does not combine map and scan frames

robot1/scan and robot1/map topics are working fine but some errors occurs rqt ...
Kaan Karakoç's user avatar
1 vote
0 answers
57 views

Issue when robot tries to align with target orientation

I am using AMCL + Nav2 Stack for my custom robot to localize and navigate. When I send a target pose, the robot moves toward it properly. However, when it reaches the target position and tries to ...
jcgarciaca's user avatar
0 votes
0 answers
23 views

Knowing whether the robot is delocalised or not by observing relevant data

The way that we know if a robot is delocalised is by opening RViz and observing the laser's scan data with respect to the static map on the ...
user37666's user avatar
0 votes
0 answers
69 views

Localization problem of my robot in RVİZ environment at first run

I am doing research for the first positioning for my robot to be done correctly on the map. I have done various researches and applications (such as amcl, ICP) for these and I am still continuing. But ...
furkancetin's user avatar
1 vote
1 answer
158 views

AMCL does not localize my robot

I am trying to use AMCL (nav2_amcl) with my custom robot, but localization doesn't seem to run. I launch my robot frames and a transform from ...
jcgarciaca's user avatar
0 votes
2 answers
49 views

How to remap tf publication of AMCL

I'm trying to perform Localization in outdoor and indoor situations, and I would like to remap the /tf publisher from AMCL node so I can redirect it to a mux where I could select which algorithm ...
ÁngeLoGa's user avatar
  • 172
0 votes
0 answers
28 views

questions about amcl and hector slam

My current urdf files have base_link and base_footprint as parents and child links , however i want to use amcl , i have another launch file for amcl which publishes the odom frame , but my urdf files ...
tim's user avatar
  • 1
0 votes
0 answers
108 views

how to add a TF for odom --> base_link?

I'm trying to do amcl and currently my map is not working and found the solution, which is the odom --> base_link TF currently not found, how do I create a odom --> base_link TF? Currently ...
nolan's user avatar
  • 1
0 votes
2 answers
89 views

Robot getting spawned at the corner of map

using ubuntu 18.04 melodic i am currently trying to do amcl with my robot with a generated map from gmapping my map now cannot be spawned normally and the robot is alw at the corner , please help me , ...
tim's user avatar
  • 1
0 votes
0 answers
49 views

Unable to localize multi robot due to amcl not receiving scan data

Hello guys i am working on multi robot. All works well. I am able to get topics for different robot for their namespaces . I am also able to echo the scan topics , provide the map by the map-server ...
Davies Ogunsina's user avatar
0 votes
1 answer
101 views

Rviz Amcl spreading over time when stayin still

I am trying Multirobot navigation with the navigation_stack and the Rviz, in ros noetic. When i publish the amcl when starting, the spread looks normal. Then i publish a goal, the robot moves and the ...
Michalis's user avatar
0 votes
1 answer
140 views

No map received in rviz

Iam trying to launch the amcl.launch file with MapServer node. and I have taken the map with octomap and want to visualize the map in 3d. so I have created a launch file for that. but i am getting ...
Uday Kumar's user avatar
0 votes
1 answer
2 views

/scan topic comes from a camera node rather than the desired LiDAR node

Hi guys. I'm trying to use a rplidar to run amcl navigation with my pre-built map on Turtlebot2, ROS Kinetic. Below is my amcl launch file: ...
user avatar
0 votes
1 answer
125 views

How to overcome Odom drift while using amcl?

Hi ros community How to fix the Odom drift I have only used laser_scan for localisation. And also When I was doing amcl while launching it, the pose direction is perpendicular to my robot, I played ...
user avatar
0 votes
1 answer
310 views

No laser scan received (and thus no pose updates have been published) for 18.974000 seconds. Verify that data is being published on the /scan topic

Hi all, i already searched this question on all over answers.ros.org, but i didnt found answer on the issue i have. I built a custom 4 wheel bot and i added a navigation stack(map, move_base, amcl and ...
user avatar
0 votes
1 answer
32 views

How to make ira_laser_tools work with AMCL/GMCL and GMapping?

I am currently on ROS Noetic Ubuntu 20.04 LTS. I am not doing this in simulation, although I believe you will run into the same problem if done in simulation. The problem is that GMapping or AMCL/GMCL ...
user avatar
0 votes
1 answer
12 views

[ROS + Gazebo + SLAM] How to get specific goal from map?

Hi everybody, I have set up navigation stack for my mobile robot. Now I want to get specific goal from map (or LaserScan data) based on the shape of scan (let's say I have model of rack with multiple ...
user avatar
0 votes
2 answers
29 views

Is it okay to use ROS Navigation Stack for a heavy(200kg +) robot?

Hello, I wanted to know if we can use the amcl, move_base along with existing planners like TEB and cost maps plugins for a robot weighing 200+ kgs? I intend to operate the robot at an average ...
user avatar
0 votes
1 answer
236 views

AMCL cannot publish a pose or update the transform. Please set the initial pose

I'm a ROS2 n00b trying to learn navigation2. I have a lot of experience with ROS1's navigation stack but am having basic issues with navigation2. I'm running ROS2 galactic built from source on an ...
user avatar
0 votes
1 answer
23 views

How to distribute amcl's particles all over the map?

Hi, when you first launch Rviz with particle cloud, the particles is gathered around the robot model, I wonder how to make those particles distribute all over my map? Thanks in advance. Originally ...
user avatar
0 votes
1 answer
15 views

AMCL aborts global costmap

I have problems with Rviz2 when pose estimating a robot. I get the following error: ...
user avatar
0 votes
1 answer
30 views

Can odometry be calculated with LaserScan alone?

I am building a robot and implementing autonomous navigation using gmapping, amcl, and move_base. From my understanding the amcl package compares the map to lidar data (sensor_msgs/LaserScan) to ...
user avatar
0 votes
2 answers
85 views

Laser Scanner Rotation when the robot is moving

Hello there everyone, I am running into an issue with the navigation stack with move base and AMCL in ROS. The issue is, every time the robot rotates by a certain degree, the laser also rotates and ...
user avatar
0 votes
1 answer
26 views

AMCL node crashed

Hi, I am new in ROS2. Currently I am trying AMCL implementation on the real robot. I had a lidar mounted on the robot. Whenever, I started the AMCL node, it is able to be activated fine till " I ...
user avatar
0 votes
1 answer
207 views

What difference between SLAM locating and AMCL locating

SLAM can analysis the environment and locating iteself. And AMCL can locate itself with saved map. What difference between the two locating method of SLAM and AMCL? Because SLAM can locate, the AMCL ...
user avatar
0 votes
1 answer
76 views

Best localization algorithms available in ROS2/ROS1

I have used slam_toolbox and AMCL are these the only options. If we only have slam_toolbox and AMCL then which one is preferred strictly for localization(no mapping ) for large warehouses with a ...
user avatar
0 votes
1 answer
8 views

EKF start to predict after amcl stop sending pose

Hello, I'm trying to use robot_localization to fuse amcl_pose with encoder odom, and latter GPS. The experiment is basing on Turtlebot3, gazebo and ros2-foxy. It's working well if the robot is moving. ...
user avatar
0 votes
1 answer
51 views

Navigation path planning over long distances

I'm having an issue with move_base and/or Navfn whereby the control system can't plan a path for anything over a certain distance. The path planning (and following) works fine for short nav goals: ...
user avatar
0 votes
1 answer
46 views

navigation2 - Set two scan topics to AMCL

Hi, Env: ROS2 Foxy / Ubuntu 20.04 I have a robot navigating with two Lidars, so I have two topics /scan_front and /scan_back. in the costmap i am setting observation_sources: scan1 scan2, but how can ...
user avatar
0 votes
1 answer
3 views

Output update of robot position coordiantes

Hi all, I did a mapping of my static area with hector_slam using RP-Lidar 2D scanner and then i finished path planning using husky_slam, now i'm about to make my robot navigate through the map. The ...
user avatar
0 votes
1 answer
18 views

robot_localization (ekf node) output is not stable for a long time

Hi. I am using ekf_localization_node for fusing imu, wheel odometry and amcl_pose ( My config is as follow ) The reason why i am using amcl_pose; When i use ...
user avatar
0 votes
1 answer
48 views

Localization, using robot_localization and robot_pose_ekf

What is the difference between robot_pose_ekf (package) and robot_localization. I have encoder odometry, lidar scan and imu sensor data.... How can we combine these sensor to get better localization ...
user avatar
0 votes
1 answer
136 views

Control loop missed its desired rate of 20.0000Hz... the loop actually took 0.1600 seconds

Hi there, why is this happening after I send a nav goal? ...
user avatar
0 votes
1 answer
4 views

When robot rotates, pose arrows diverges(which makes turning difficult)

Hello, There is no problem in navigation except this one. Robot tries to choose the closest path possible but this makes robot rotate sharp turn. That is why in the middle of narrow path, robot stops ...
user avatar
0 votes
1 answer
9 views

Amcl localization accurate, but slightly offset from lidar data

I have what looks like a very good localization of the robot to the map. But when overlaid with the current lidar scan data, the localization is just a little offset, but with high confidence. See ...
pitosalas's user avatar
  • 465
0 votes
1 answer
21 views

amcl package not on ROS Noetic

Hi, I recently installed ROS Noetic from this link on Ubuntu 20.04, and was planning on using the amcl package for localization applications. It seems that the amcl package is not located in the ...
user avatar
0 votes
1 answer
8 views

Does AMCL still work in an edited map?

I have a global map of a big room but edited the .pgm file and added a wall so that the robot doesn't drive under a table. My question is does AMCL use this map to correct the localisation of the ...
user avatar
0 votes
1 answer
17 views

Amcl particlecloud topic not publishing

Hi, I would like to know why rviz is not showing the particle cloud for any of my robots. Below I have provided my navigation stack launch file and my amcl parameters yaml file. Everything works (e.g. ...
user avatar

1
2 3 4 5
8