0
$\begingroup$

Rosanswers logo

EDIT:

It seems like I messed up some settings for my static ip; new-installed Ubuntu now it works

Old Text

Hi,

im new to melodic (and ubuntu) but had success installing ros melodic on different machines so far.

Now, I want to install it on my raspberry pi 3b, where 18.04 (Server) is running so far.

I followed the installation instructions, but I get an error at 1.3 - "Set up your keys":

gpg: no valid OpenPGP data found.

sudo apt update then yields the following:

Hit:1 http://ports.ubuntu.com/ubuntu-ports bionic InRelease Hit:2 http://ports.ubuntu.com/ubuntu-ports bionic-updates InRelease Hit:3 http://ports.ubuntu.com/ubuntu-ports bionic-backports InRelease Hit:4 http://ports.ubuntu.com/ubuntu-ports bionic-security InRelease Get:5 http://packages.ros.org/ros/ubuntu bionic InRelease [4680 B] Err:5 http://packages.ros.org/ros/ubuntu bionic InRelease The following signatures couldn't be verified because the public key is not available: NO_PUBKEY F42ED6FBAB17C654 Reading package lists... Doneros-base W: GPG error: http://packages.ros.org/ros/ubuntu bionic InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY F42ED6FBAB17C654 E: The repository 'http://packages.ros.org/ros/ubuntu bionic InRelease' is not signed. N: Updating from such a repository can't be done securely, and is therefore disabled by default. N: See apt-secure(8) manpage for repository creation and user configuration details.

(Sorry for the formatting, dont know how to resolve this).

Finally, when i want to install:

E: Unable to locate package ros-melodic-ros-base

I hope I've provided all needed information:)

Thanks for your help. Robin


Originally posted by robin_rob96 on ROS Answers with karma: 46 on 2021-07-02

Post score: 0


Original comments

Comment by gvdhoorn on 2021-07-06:
if you figured out what caused your problems, please post your solution as an answer and accept your own answer.

That way future readers would benefit from what you found out.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

When I first installed Ubuntu on the pi, I followed a random tutorial for setting a static ip in my local network - I forgot about details. Turns out, this was what made the error; after a clean ubuntu install, my problems were gone.


Originally posted by robin_rob96 with karma: 46 on 2021-07-06

This answer was ACCEPTED on the original site

Post score: 0

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.