0
$\begingroup$

Rosanswers logo

Without using ADE

I am trying to install Autoware.Auto without using ADE. I installed ros-foxy-desktop via Debian packages, i.e by typing sudo apt install ros-foxy-desktop in terminal. I also installed all the dependencies as is written in the Installation document of Autoware.Auto.

The problem is that when I build the Autoware.Auto packages with colcon build --cmake-args -DCMAKE_BUILD_TYPE=RelWithDebInfo some packages fail. At the end I see such a message:

Summary: 94 packages finished [4min 53s]
  11 packages had stderr output: ament_acado autoware_auto_common lanelet2_global_planner mpc_controller ndt ndt_mapping_nodes ndt_nodes point_cloud_mapping rosapi spinnaker_camera_driver spinnaker_camera_nodes

To be more specific, here is the first stderr message:

--- stderr: autoware_auto_common                                                                                                                                                               
CMake Warning at CMakeLists.txt:53 (find_package):
  Found package configuration file:

    /opt/ros/foxy/share/ament_cmake_cpplint/cmake/ament_cmake_cpplintConfig.cmake

  but it set ament_cmake_cpplint_FOUND to FALSE so package
  "ament_cmake_cpplint" is considered to be NOT FOUND.


CMake Warning at CMakeLists.txt:58 (find_package):
  Found package configuration file:

    /opt/ros/foxy/share/ament_cmake_uncrustify/cmake/ament_cmake_uncrustifyConfig.cmake

  but it set ament_cmake_uncrustify_FOUND to FALSE so package
  "ament_cmake_uncrustify" is considered to be NOT FOUND.


---
Finished <<< autoware_auto_common [23.8s]

I am using ubuntu 20.04.

##Inside ADE I have to note that the same problem exists inside ADE. I use the installation guide and when I run build the project, I find similar errors.

Summary: 93 packages finished [2min 48s]
  12 packages had stderr output: ament_acado autoware_auto_common had_map_utils lanelet2_global_planner mpc_controller ndt ndt_mapping_nodes ndt_nodes point_cloud_mapping rosapi spinnaker_camera_driver spinnaker_camera_nodes

My question is that why I see the above stderr? Does it mean that I missed some dependencies? By the way, I installed all dependencies from Autoware.Auto documentation. I appreciate any suggestion.


Originally posted by ashakeri on ROS Answers with karma: 3 on 2021-04-23

Post score: 0


Original comments

Comment by jpace121 on 2021-04-24:
Are cpplint and uncrustify installed?

Comment by ashakeri on 2021-04-26:
@jpace121 Yes they are installed but the same problem exist. I installed the cpplint via "pip install cpplint".

Comment by christophebedard on 2021-04-26:
It's not actually failing though. It's a warning. Maybe just proceed with whatever you wanted to do and see if it works?

Comment by ashakeri on 2021-05-03:
@christophebedard The functionalities that I want is not working. I do everything according to this documentation but it does not work. According to your answer I think there should be something missing in the documentation. Now, I am trying to find a solution.

Comment by christophebedard on 2021-05-03:
I'd suggest you open a new question for that other problem.

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

It's not actually failling.

this

Finished <<< autoware_auto_common [23.8s]

and this

Summary: 93 packages finished [2min 48s]

show that it built just fine. You're just getting a CMake warning. Getting X packages had stderr output is fairly normal.

If building had actually failed, you would be getting different messages, e.g.

Failed   <<< autoware_auto_common [1.23s]

and

Summary: X packages finished [1.23s]
  1 package failed: autoware_auto_common

Seems like the warnings were fixed recently: https://gitlab.com/autowarefoundation/autoware.auto/AutowareAuto/-/merge_requests/926/diffs


Originally posted by christophebedard with karma: 641 on 2021-04-30

This answer was ACCEPTED on the original site

Post score: 2


Original comments

Comment by ashakeri on 2021-05-03:
Thanks for the feedback. So I conclude that the problems that I have are not related to building the packages. For example one of the problems is that when I run the ros2 launch autoware_auto_launch autoware_auto_visualization.launch.py command, I get this error: Package 'autoware_auto_launch' not found.

Comment by christophebedard on 2021-05-03:
at least not related to the warning you get when building autoware_auto_common

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.