0
$\begingroup$

Rosanswers logo

I'm using Ros Melodic, Gazebo 9, Ubuntu 18.04. I have downloaded a pkg from github as zip and extracted and pasted in the home/usr/catkin_ws/src and when I try to build the pkg by using catkin build , as i have used this command for my previous packages. but it through a lot of error can any one help me to resolve these. I'm attaching a screenshot of the terminal ![screenshot1.png] ![screenshot2.png]

rethen@Rethen:~/catkin_ws$ catkin build

Profile: default Extending: [cached] /opt/ros/melodic Workspace: /home/rethen/catkin_ws

Build Space: [exists] /home/rethen/catkin_ws/build Devel Space: [exists] /home/rethen/catkin_ws/devel Install Space: [unused] /home/rethen/catkin_ws/install Log Space: [exists] /home/rethen/catkin_ws/logs Source Space: [exists] /home/rethen/catkin_ws/src DESTDIR: [unused] None

Devel Space Layout: linked Install Space Layout: None

Additional CMake Args: None Additional Make Args: None Additional catkin Make Args: None Internal Make Job Server: True Cache Job Environments: False

Whitelisted Packages: None Blacklisted Packages: None

Workspace configuration appears valid.

[build] Found '11' packages in 0.0 seconds.
[build] Package table is up to date.
Starting >>> ebot_controller
Starting >>> ebot_description
Starting >>> ebot_gazebo
Starting >>> gazebo_ros_link_attacher
Starting >>> maze_robotcraft
Starting >>> pid_tune
Starting >>> pkg_techfest_imc
Starting >>> racing
Starting >>> smart_mouse_sim
Starting >>> stage_launch
Starting >>> vitarana_drone


Errors << smart_mouse_sim:cmake /home/rethen/catkin_ws/logs/smart_mouse_sim/build.cmake.002.log CMake Error at /home/rethen/catkin_ws/src/smartmouse_simulator_master/src/core/test/CMakeLists.txt:14 (gtest_discover_tests): Unknown CMake command "gtest_discover_tests".

cd /home/rethen/catkin_ws/build/smart_mouse_sim; catkin build --get-env smart_mouse_sim | catkin env -si /usr/bin/cmake /home/rethen/catkin_ws/src/smartmouse_simulator_master --no-warn-unused-cli -DCATKIN_DEVEL_PREFIX=/home/rethen/catkin_ws/devel/.private/smart_mouse_sim -DCMAKE_INSTALL_PREFIX=/home/rethen/catkin_ws/install; cd - ............................................................................... Failed << smart_mouse_sim:cmake [ Exited with code 1 ]
Failed <<< smart_mouse_sim [ 0.2 seconds ]
Finished <<< ebot_controller [ 0.2 seconds ]
Finished <<< ebot_description [ 0.2 seconds ]
Finished <<< pkg_techfest_imc [ 0.2 seconds ]
Finished <<< gazebo_ros_link_attacher [ 0.4 seconds ]
Finished <<< pid_tune [ 0.4 seconds ]
Finished <<< maze_robotcraft [ 0.4 seconds ]
Finished <<< ebot_gazebo [ 0.2 seconds ]


Errors << racing:cmake /home/rethen/catkin_ws/logs/racing/build.cmake.002.log CMake Error at /opt/ros/melodic/share/catkin/cmake/catkinConfig.cmake:83 (find_package): Could not find a package configuration file provided by "move_base_msgs" with any of the following names:

move_base_msgsConfig.cmake
move_base_msgs-config.cmake

Add the installation prefix of "move_base_msgs" to CMAKE_PREFIX_PATH or set "move_base_msgs_DIR" to a directory containing one of the above files. If "move_base_msgs" provides a separate development package or SDK, be sure it has been installed. Call Stack (most recent call first): CMakeLists.txt:6 (find_package)

cd /home/rethen/catkin_ws/build/racing; catkin build --get-env racing | catkin env -si /usr/bin/cmake /home/rethen/catkin_ws/src/MazeRunnerROS-master/racing --no-warn-unused-cli -DCATKIN_DEVEL_PREFIX=/home/rethen/catkin_ws/devel/.private/racing -DCMAKE_INSTALL_PREFIX=/home/rethen/catkin_ws/install; cd - ............................................................................... Failed << racing:cmake [ Exited with code 1 ]
Failed <<< racing [ 1.0 seconds ]
Finished <<< vitarana_drone [ 0.5 seconds ]
Finished <<< stage_launch [ 0.2 seconds ]
[build] Summary: 9 of 11 packages succeeded.
[build] Ignored: None.
[build] Warnings: None.
[build] Abandoned: None.
[build] Failed: 2 packages failed.
[build] Runtime: 1.4 seconds total.


Originally posted by Rethen on ROS Answers with karma: 13 on 2020-11-15

Post score: 1

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

I think you missed to install move_base_msgs package

Make sure to install all the dependencies

You can install all the dependencies by running this instruction inside your workspace

rosdep install --from-paths src --ignore-src -r -y


Originally posted by Moneera Banjar with karma: 108 on 2020-11-15

This answer was ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.