0
$\begingroup$

Rosanswers logo

I am using turtlebot for my obstacle avoid robot using ultrasonic sensors.I am using 8 ultrasonic sensors.I dont know where the error is but ths it is successfully seen in gazebo but while I am launching it in rviz. `[ERROR] [1596993808.761522983]: Failed to build tree: parent link [base_footprint] of joint [sonar_front_joint] not found. This is not valid according to the URDF spec. Every link you refer to from a joint needs to be explicitly defined in the robot description. To fix this problem you can either remove this joint [sonar_front_joint] from your urdf file, or add "" to your urdf file. [robot_state_publisher-3] process has died [pid 4060, exit code 255, cmd /opt/ros/kinetic/lib/robot_state_publisher/state_publisher __name:=robot_state_publisher __log:=/home/lekhasree/.ros/log/09d44e52-da65-11ea-afc1-e8d0fc91b2fd/robot_state_publisher-3.log]. log file: /home/lekhasree/.ros/log/09d44e52-da65-11ea-afc1-e8d0fc91b2fd/robot_state_publisher-3*.log

PLese help me out with this error

The urdf file is https://github.com/Lekha03/urdf-of-ultrasonic-sensors-with-turtlebot.git[link text](https://github.com/Lekha03/urdf-of-ultrasonic-sensors-with-turtlebot.git)

In this I have inserted the required files. Turtlebot isnt visible in RVIZ, what should I do.


Originally posted by sree on ROS Answers with karma: 7 on 2020-08-09

Post score: 0

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

You did not specify the link base_footprint in your urdf file. I assume this link is specified in the turtlebot description, which you should include in your urdf.


Originally posted by rfn123 with karma: 146 on 2020-08-09

This answer was ACCEPTED on the original site

Post score: 0


Original comments

Comment by sree on 2020-08-10:
Thank you ...It is not showing errors .But my turtlebot is not visible in RVIZ.,only a rectangular is being visible.

Comment by rfn123 on 2020-08-10:
You need to add RobotModel in the Rviz Panel in order to see the turtlebot

Comment by sree on 2020-08-10:
Yeah I am Inserting But no turtlebot is visible.Only rectangular box is visible.

Comment by sree on 2020-08-10:
Can please check the files.Should I insert anything more for turtelbot to be visible.

Comment by Tahir M. on 2020-08-11:
If you don't have a real robot than you might have to include joint state publisher to fake the joints. You might be seeing now only the fixed joints so for non-fixed you need joint state publisher.

Comment by sree on 2020-08-11:
Yeah, I did It but a BOX is being Visible. Cant I visualize my gazebo world on RVIZ

Comment by rfn123 on 2020-08-11:
I am not sure if the urdf included in your link is the actual one you are using, but from the commented parts I see that you are specifying boxes as visuals, hence the box in Rviz.

<visual>
      <origin xyz="0 0 0" rpy="0 0 0"/>
      <geometry>
        <box size="0.02 0.01 0.01"/>
      </geometry>
</visual>   

You need to specify meshes if you want them to be visible in Rviz

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.