0
$\begingroup$

Rosanswers logo

Good Afternoon All,

I am going through the tutorial at : http://wiki.ros.org/ROS/Tutorials/UnderstandingNodes. I ran the command : rosrun turtlesim turtlesim_node and it generated the error :

/opt/ros/noetic/lib/turtlesim/turtlesim_node: error while loading shared libraries: libQt5Core.so.5: cannot open shared object file: No such file or directory

I verified that libQt5Core.so.5 is installed, and idea on how to resolve? Please advise?

Regards,


Originally posted by chm007 on ROS Answers with karma: 34 on 2020-06-12

Post score: 0


Original comments

Comment by achille on 2020-06-12:
This doesn't seem to be an issue with ROS, but rather with your system. See here for example. If that doesn't help, can you provide system details?

Comment by chethw on 2021-06-16:
Im trying to install ros/gazebo using WSL in ubuntu 20.4 and getting the same error. any clue to fix this?

$\endgroup$

1 Answer 1

0
$\begingroup$

Rosanswers logo

Hello,

I have solved the same problem.

Maybe this problem is due to the version of WSL in ubuntu 20.04.

To solve this problem, refer to this URL: link text

whereis libQt5Core.so.5
# copy that address
sudo strip --remove-section=.note.ABI-tag /usr/lib/x86_64-linux-gnu/libQt5Core.so.5

Good Luck.


Originally posted by KindlyAccept with karma: 26 on 2021-08-11

This answer was ACCEPTED on the original site

Post score: 1


Original comments

Comment by chm007 on 2022-03-25:
This worked thanks

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.