1
$\begingroup$

Rosanswers logo

I am running Melodic in Ubuntu 18.04 in a VM.

I tried uninstalling and the reinstalling the package from the git (as found in the documentation), but ran into the same error. I was able to build the package using rosbuild and build the workspace using catkin_make_isolated

When I run the command: roslaunch robot_pose_ekf robot_pose_ekf.launch I get the following as my output:

parallels@parallels:~/autorobot_ws$ roslaunch robot_pose_ekf robot_pose_ekf.launch 
... logging to /home/parallels/.ros/log/3b031c06-9019-11ea-a883-001c42bcca12/roslaunch-parallels-7626.log
Checking log directory for disk usage. This may take a while.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://parallels:40787/

SUMMARY
========

PARAMETERS
 * /robot_pose_ekf/base_footprint_frame: base_footprint
 * /robot_pose_ekf/freq: 30.0
 * /robot_pose_ekf/imu_used: True
 * /robot_pose_ekf/odom_used: True
 * /robot_pose_ekf/output_frame: odom_combined
 * /robot_pose_ekf/sensor_timeout: 1.0
 * /robot_pose_ekf/vo_used: True
 * /rosdistro: melodic
 * /rosversion: 1.14.5

NODES
  /
    robot_pose_ekf (robot_pose_ekf/robot_pose_ekf)

ROS_MASTER_URI=http://localhost:11311

ERROR: cannot launch node of type [robot_pose_ekf/robot_pose_ekf]: Cannot locate node of type [robot_pose_ekf] in package [robot_pose_ekf]. Make sure file exists in package path and permission is set to executable (chmod +x)
No processes to monitor
shutting down processing monitor...
... shutting down processing monitor complete

I then ran rosrun robot_pose_ekf wtf.py as per some advice as suggested in the troubleshooting guide. I got the following as my output:

Traceback (most recent call last):
  File "/home/parallels/autorobot_ws/src/robot_pose_ekf/scripts/wtf.py", line 4, in <module>
    from robot_pose_ekf.srv import GetStatus, GetStatusRequest
ImportError: No module named robot_pose_ekf.srv

Originally posted by jkaplan1123 on ROS Answers with karma: 21 on 2020-05-07

Post score: 1

$\endgroup$

2 Answers 2

0
$\begingroup$

Rosanswers logo

Did you check the usual suspects like sourcing the setup.bash file ?


Originally posted by nihalsoans91 with karma: 21 on 2020-05-07

This answer was NOT ACCEPTED on the original site

Post score: 1


Original comments

Comment by jkaplan1123 on 2020-05-07:
Yes I have. I run source ~/autorobot_ws/devel/setup.bash

$\endgroup$
0
$\begingroup$

Rosanswers logo

For some reason, downloading the catkin tools toolbox, running catkin init on my workspace followed by catkin clean and catkin build worked. I have no idea why, but it did. Hope this helps anyone else with the same issue in the future.


Originally posted by jkaplan1123 with karma: 21 on 2020-05-10

This answer was NOT ACCEPTED on the original site

Post score: 1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.